Project

General

Profile

Bug #11163

RGW Swift API: add support for URL schema compatible with Swift

Added by Radoslaw Zarzynski over 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

RGW currently supports multiple accounts (unfortunately without separate namespaces - see #5073). The account name is obtained from auth mechanism and URL doesn't contain it. This introduces incopability with OpenStack Object Storage API which says:

The public URL that is the HTTP endpoint from where you can access Object Storage. It includes the Object Storage API version number and your account name. For example, https://23.253.72.207/v1/my_account.

There is a configuration option rgw_swift_tenant_name, but it is still not enough due to the lack of support for multiple accounts in that way.

Associated revisions

Revision a99f5827 (diff)
Added by Radoslaw Zarzynski almost 7 years ago

rgw: improve support for Swift's URL schema with account name inside.

Fixes: #11163
Signed-off-by: Radoslaw Zarzynski <>

History

#1 Updated by Radoslaw Zarzynski over 7 years ago

  • Status changed from New to In Progress
  • Assignee set to Radoslaw Zarzynski

#2 Updated by Radoslaw Zarzynski over 7 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Casey Bodley almost 3 years ago

  • Status changed from Fix Under Review to Closed

Also available in: Atom PDF