Project

General

Profile

Bug #11061

BuildRequires missing for RHEL 6.5

Added by Loïc Dachary almost 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
rpm
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

On https://ceph.com/git/?p=ceph.git;a=commit;h=a19f92cfa64741fb801d0e814dd712ab52d4d221 the following patch is necessary to run-make-check.sh on a fresh VPS

LSB Version:    :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
Distributor ID: RedHatEnterpriseServer
Description:    Red Hat Enterprise Linux Server release 6.5 (Santiago)
Release:        6.5
Codename:       Santiago

EPEL was installed with
File Edit Options Buffers Tools Help                                                                                                 
SUDO=sudo
$SUDO yum install -y yum-utils
 EPEL_VERSION=$(lsb_release -rs | cut -f1 -d.)
 $SUDO yum-config-manager --add-repo https://dl.fedoraproject.org/pub/epel/$EPEL_VERSION/x86_64/
 $SUDO yum install --nogpgcheck -y epel-release
 $SUDO rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-$EPEL_VERSION
 $SUDO rm -f /etc/yum.repos.d/dl.fedoraproject.org*

diff --git a/ceph.spec.in b/ceph.spec.in
index d284844..4c80cfe 100644
--- a/ceph.spec.in
+++ b/ceph.spec.in
@@ -45,7 +45,6 @@ BuildRequires:        gdbm
 BuildRequires: hdparm
 BuildRequires: libaio-devel
 BuildRequires: libcurl-devel
-BuildRequires: libedit-devel
 BuildRequires: libxml2-devel
 BuildRequires: libuuid-devel
 BuildRequires: libblkid-devel >= 2.17
@@ -95,7 +94,6 @@ BuildRequires:        fdupes
 Requires:      gdisk
 BuildRequires: nss-devel
 BuildRequires: keyutils-libs-devel
-BuildRequires: libatomic_ops-devel
 Requires:      gdisk
 Requires(post):        chkconfig
 Requires(preun):chkconfig

Associated revisions

Revision 830a4a1b (diff)
Added by Loic Dachary almost 9 years ago

tests: install-deps.sh install EPEL and RHEL Optional

On CentOS and RHEL, some dependencies come from EPEL.

Always enable RHEL Optional repository for RHEL as packages such as
packages such as libatomic_ops-devel or libedit-devel are only found
there in RHEL 6.5.

http://tracker.ceph.com/issues/11061 Refs: #11061

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loïc Dachary almost 9 years ago

  • Description updated (diff)

#2 Updated by Loïc Dachary almost 9 years ago

  • Status changed from New to Rejected

cat > /etc/yum.repos.d/rhel.repo <<EOF
[rhel6-server]
name=My Red Hat Enterprise Linux Server $releasever - $basearch
baseurl=http://apt-mirror.front.sepia.ceph.com/rhel6repo-server/
gpgcheck=0
enabled=1

[rhel6-server-optional]
name=My Red Hat Enterprise Linux Optional $releasever - $basearch
baseurl=http://apt-mirror.front.sepia.ceph.com/rhel6repo-server-optional
gpgcheck=0
enabled=1
EOF

was necessary and the missing packages were found there.

#3 Updated by Ken Dreyer almost 9 years ago

Hi Loic, a couple of things stood out to me here.

Firstly, this is tricky because we are not properly entitling any of our RHEL hosts in our labs, so the "RHEL Optional" repository name in the Ceph labs is slightly different from the repository name that a normal individual user might use on RHEL. (See #11022 where Dan/Zack/I are trying to fix this.)

Secondly, it appears that your /etc/yum.repos.d/rhel.repo is pointing at apt-mirror. Was that something that you'd configured yourself, or did Chef do that? The /etc/yum.repos.d/rhel.repo file is not really supposed to be edited by hand - instead, it's managed dynamically by the subscription-manager utility. If a server is entitled to Red Hat, /etc/yum.repos.d/rhel.repo will be periodically refreshed / overwritten. (There is a way to disable this, but it's not very standard). It's probably best to leave rhel.repo alone and just add custom apt-mirror repositories in other .repo files. (I thought that's what Chef did).

(By the way, all Red Hat staff should have access to entitlements. I'll reach out to you individually about getting your Customer Portal account set up if it's not set up already.)

Setting those questions aside for a moment, I'll address your question from the mailing list, "advice on adding the rhel6-server-optional repo".

When a RHEL host is properly entitled (using the subscription-manager utility), then subscription-manager repos --list will show the various repositories that are available from Red Hat. This includes RHEL Optional. For the RHEL Optional repository, the name of the repository is "rhel-7-server-optional-rpms" on RHEL 7 or "rhel-6-server-optional-rpms" on RHEL 6.

To enable the RHEL Optional repository for a single yum operation, you can pass the --enablerepo flag:

yum --enablerepo=rhel-7-server-optional-rpms install libedit-devel

You can probably pass --enablerepo to the yum-builddep command in install-deps.sh as well.

To enable the RHEL Optional repository on a permanent basis, so that you don't need to specify --enablerepo to yum, you can run subscription-manager repos:

subscription-manager repos --enable=rhel-7-server-optional-rpms

Under the hood, this will flip the Enabled=0 to Enabled=1 in /etc/yum.repos.d/rhel.repo.

This is probably the approach we'd want to take with install-deps.sh. We're already enabling EPEL by default, and since EPEL packages sometimes depend on RHEL Optional packages, I think it makes sense to permanently enable both.

Also available in: Atom PDF