Project

General

Profile

Bug #10982

ceph-fuse: remount for dentry trim can fail during unmount

Added by Greg Farnum over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
03/02/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

http://pulpito.ceph.com/teuthology-2015-02-26_23:04:03-fs-hammer-testing-basic-multi/780938/
http://pulpito.ceph.com/teuthology-2015-02-26_23:04:03-fs-hammer-testing-basic-multi/780940/

At first glance, it looks like the client is unmounting, and during the shutdown passes we try to trim dentries and trigger our remount callback. It fails and hits an assert. We probably just shouldn't be triggering it during shutdown?

Associated revisions

Revision 71f26862 (diff)
Added by Greg Farnum over 4 years ago

Client: do not require successful remount when unmounting

Fixes: #10982

Signed-off-by: Greg Farnum <>

Revision 3530a25a (diff)
Added by Greg Farnum over 4 years ago

Client: do not require successful remount when unmounting

Fixes: #10982

Signed-off-by: Greg Farnum <>
(cherry picked from commit 71f2686252ffe29d0234cc8be7304be1450d090e)

History

#1 Updated by Greg Farnum over 4 years ago

  • Status changed from New to Pending Backport

Zheng merged the initial PR; I think I need to backport it.

#2 Updated by Greg Farnum over 4 years ago

  • Status changed from Pending Backport to Resolved

Pushed to hammer in commit:3530a25ae73bda2da63603373f1b3a56b63d8a00

Also available in: Atom PDF