Project

General

Profile

Bug #10740

teuthology: nfs test getting EBUSY on umount

Added by Greg Farnum over 4 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
NFS (Linux Kernel)
Target version:
-
Start date:
02/04/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

ubuntu@teuthology:/a/teuthology-2015-02-01_23:10:01-knfs-next-testing-basic-multi/735724

This was previously #8576, but the above is the first recurrence I've seen in a month or two...

History

#2 Updated by Greg Farnum over 4 years ago

  • Status changed from New to Can't reproduce

We haven't seen this again. I think the next branch must have been horribly out of date.

#3 Updated by Greg Farnum over 4 years ago

  • Status changed from Can't reproduce to Verified

We just saw this again: http://pulpito.ceph.com/teuthology-2015-04-20_23:10:01-knfs-next-testing-basic-multi/856921/

Much to my frustration, we are definitely running with the previous fix:

2015-04-21T07:13:07.908 INFO:teuthology.orchestra.run.burnupi04:Running: 'sudo lsof -V +D /home/ubuntu/cephtest/mnt.0'
2015-04-21T07:13:08.046 INFO:teuthology.orchestra.run.burnupi04.stdout:lsof: no file use located: /home/ubuntu/cephtest/mnt.0
2015-04-21T07:13:08.050 INFO:teuthology.orchestra.run.burnupi04:Running: 'sudo exportfs -au'
2015-04-21T07:13:08.092 INFO:teuthology.orchestra.run.burnupi04:Running: 'sudo rpc.nfsd 0'
2015-04-21T07:13:08.167 INFO:teuthology.orchestra.run.burnupi04:Running: 'sudo exportfs -f'

#4 Updated by Patrick Donnelly 6 months ago

  • Status changed from Verified to Rejected

knfs is dead.

Also available in: Atom PDF