Project

General

Profile

Bug #10623

rhel7 knfs does not support nfs v3

Added by Greg Farnum over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Sandon Van Ness
Category:
-
Target version:
-
Start date:
01/23/2015
Due date:
% Done:

100%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://qa-proxy.ceph.com/teuthology/teuthology-2015-01-21_23:10:01-knfs-master-testing-basic-multi/717159/

Attempt from Ubuntu Precise client to mount nfs served by a RHEL7 server gets

2015-01-22T09:39:15.471 DEBUG:teuthology.task.nfs:mount -o rw,hard,intr,nfsvers=3 plana77.front.sepia.ceph.com:/home/ubuntu/cephtest/mnt.0 /home/ubuntu/cephtest/mnt.1
2015-01-22T09:39:15.471 INFO:teuthology.orchestra.run.plana58:Running: 'mkdir -- /home/ubuntu/cephtest/mnt.1'
2015-01-22T09:39:15.480 INFO:teuthology.orchestra.run.plana58:Running: 'sudo mount -o rw,hard,intr,nfsvers=3 plana77.front.sepia.ceph.com:/home/ubuntu/cephtest/mnt.0 /home/ubuntu/cephtest/mnt.1'
2015-01-22T09:39:15.625 INFO:teuthology.orchestra.run.plana58.stderr:mount.nfs: requested NFS version or transport protocol is not supported

The last time I saw similar things it was because Trusty had changed its nfs config to only export NFSv4 by default, so it should be pretty easy to fix by changing a config file/option in whatever does the imaging.

History

#1 Updated by Greg Farnum over 4 years ago

  • Priority changed from Normal to High

This is starting to turn up a lot more.

#2 Updated by Sandon Van Ness over 4 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

It looks like this just had to do with /etc/exports needing a dummy entry so the service could start and chef set to enable/start the service. When I manually did this I was able to mount nfs with nfsvers=3 so it doesn't look like it had anything to do with v3/v4 afterall:

root@magna002:~# mount -o rw,hard,intr,nfsvers=3 magna128.ceph.redhat.com:/ /nfs
root@magna002:~# 
root@magna002:~# df -h
Filesystem                                               Size  Used Avail Use% Mounted on
/dev/sda1                                                917G   17G  854G   2% /
none                                                     4.0K     0  4.0K   0% /sys/fs/cgroup
udev                                                      16G  4.0K   16G   1% /dev
tmpfs                                                    3.2G  924K  3.2G   1% /run
none                                                     5.0M     0  5.0M   0% /run/lock
none                                                      16G     0   16G   0% /run/shm
none                                                     100M     0  100M   0% /run/user
10.8.128.128:6789,10.8.128.127:6789,10.8.128.126:6789:/  103T   65T   39T  63% /ceph
magna128.ceph.redhat.com:/                               930G   12G  918G   2% /nfs
root@magna002:~# umount /nfs

Fixed in commit: d4e8ea7e423864c953d21c3b65183096fcd27d83

Also available in: Atom PDF