Project

General

Profile

Bug #10579

ceph-qa-suite: can't run quota tests on kernel client

Added by Greg Farnum over 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/19/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
kceph
Labels (FS):
Pull request ID:

Description

The kclient doesn't support fs quotas. Right now we do so, because the quota test is in ceph/qa/workunits/misc, and there's a yaml fragment which runs all those.

Give the quota stuff its own workunit subdir and make sure it runs with the cfuse misc task, but not the kclient one.

Associated revisions

Revision a0af5de9 (diff)
Added by John Spray over 4 years ago

qa: move fs quota to its own dir

This is because running fs/misc on a kclient
should not include quota (quota not supported
on kernel client).

Fixes: #10579
Signed-off-by: John Spray <>

Revision 82159315 (diff)
Added by John Spray over 4 years ago

suites/fs: isolate quota task

Quota script is moved out of fs/misc so that kclient
doesn't try to run it. Update cfuse suite to find
the new location, and only enable quota for this
one script rather than enabling across
all misc tests.

Fixes: #10579
Signed-off-by: John Spray <>

History

#2 Updated by Greg Farnum over 4 years ago

  • Status changed from Need Review to Resolved

Thanks!

#3 Updated by Greg Farnum about 3 years ago

  • Component(FS) kceph added

Also available in: Atom PDF