Project

General

Profile

Bug #1056

obsync: add warning when source owner is not the same as dest owner (after mapping)

Added by Colin McCabe over 9 years ago. Updated over 9 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Category:
obsync
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

when -v is used, we should spit out a little message when we change the Owner during a source->dest copy

History

#1 Updated by Sage Weil over 9 years ago

  • Target version changed from v0.28 to v0.29

#2 Updated by Sage Weil over 9 years ago

  • Category set to obsync

#3 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_story_points set to 1
  • translation missing: en.field_position set to 666

#4 Updated by Sage Weil over 9 years ago

  • translation missing: en.field_story_points changed from 1 to 2
  • translation missing: en.field_position deleted (666)
  • translation missing: en.field_position set to 666

#5 Updated by Colin McCabe over 9 years ago

  • Status changed from New to Won't Fix

The owner of the object we create is determined by the access key and secret key supplied by the user. It can never be anything other than that, so there seems to be little point in warning.

I guess the "rgw:" target can support setting the owner to some arbitrary value, which sounds like it would be useful.

Also available in: Atom PDF