Project

General

Profile

Bug #10543

"FAILED assert(m_seed < old_pg_num)" in upgrade:giant-x-hammer-distro-basic-vps run

Added by Yuri Weinstein over 5 years ago. Updated almost 5 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/giant-x
Pull request ID:
Crash signature:

Description

Logs are in http://qa-proxy.ceph.com/teuthology/teuthology-2015-01-12_17:05:02-upgrade:giant-x-next-distro-basic-vps/700107/

2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr:    -2> 2015-01-13 18:03:39.860470 7fb361a557e0  1 -- 10.214.138.174:0/1003621 --> 10.214.139.200:6807/4428 -- osd_op(client.4135.0:17 rbd_data.102774b0dc51.0000000000000002 [set-alloc-hint object_size 4194304 write_size 4194304,write 0~4194304] 0.cca76aaa ack+ondisk+write+known_if_redirected e75) v4 -- ?+0 0x2436a00 con 0x2436690
2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr:    -1> 2015-01-13 18:03:39.912814 7fb356fc8700  1 -- 10.214.138.174:0/1003621 <== osd.2 10.214.139.84:6814/9301 1 ==== osd_map(76..77 src has 1..77) v3 ==== 643+0+0 (2763891731 0 0) 0x7fb33c00a000 con 0x24341b0
2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr:     0> 2015-01-13 18:03:39.931984 7fb356fc8700 -1 osd/osd_types.cc: In function 'bool pg_t::is_split(unsigned int, unsigned int, std::set<pg_t, std::less<pg_t>, std::allocator<pg_t> >*) const' thread 7fb356fc8700 time 2015-01-13 18:03:39.913000
2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr:osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr:
2015-01-13T15:03:39.967 INFO:tasks.workunit.client.0.vpm104.stderr: ceph version 0.87-77-g16c023d 

and then:

2015-01-13T15:03:39.976 INFO:tasks.workunit.client.0.vpm104.stderr:*** Caught signal (Aborted) **
2015-01-13T15:03:39.976 INFO:tasks.workunit.client.0.vpm104.stderr: in thread 7fb356fc8700
2015-01-13T15:03:39.976 INFO:tasks.workunit.client.0.vpm104.stderr: ceph version 0.87-77-g16c023d (16c023d8fa5575d4dd138aeee4d4fd9b8f32c0f6)
2015-01-13T15:03:39.976 INFO:tasks.workunit.client.0.vpm104.stderr: 1: rbd() [0x424055]
2015-01-13T15:03:39.976 INFO:tasks.workunit.client.0.vpm104.stderr: 2: (()+0xf710) [0x7fb35e527710]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 3: (gsignal()+0x35) [0x7fb35da96635]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 4: (abort()+0x175) [0x7fb35da97e15]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 5: (__gnu_cxx::__verbose_terminate_handler()+0x12d) [0x7fb35e0cca5d]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 6: (()+0xbcbe6) [0x7fb35e0cabe6]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 7: (()+0xbcc13) [0x7fb35e0cac13]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 8: (()+0xbcd0e) [0x7fb35e0cad0e]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 9: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x57a) [0x7fb35e9dc15a]
2015-01-13T15:03:39.977 INFO:tasks.workunit.client.0.vpm104.stderr: 10: (()+0x34ab7d) [0x7fb35ea7fb7d]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 11: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0x7a) [0x7fb35ea8df3a]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 12: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x91e) [0x7fb360f6e7ee]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 13: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x6a) [0x7fb360f6ed6a]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 14: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x22c) [0x7fb360f7640c]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 15: (Objecter::handle_osd_map(MOSDMap*)+0xe47) [0x7fb360f85517]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 16: (Objecter::ms_dispatch(Message*)+0x26b) [0x7fb360f8686b]
2015-01-13T15:03:39.978 INFO:tasks.workunit.client.0.vpm104.stderr: 17: (DispatchQueue::entry()+0x4fa) [0x7fb35eb2aa7a]
2015-01-13T15:03:39.979 INFO:tasks.workunit.client.0.vpm104.stderr: 18: (DispatchQueue::DispatchThread::entry()+0xd) [0x7fb35eb35a7d]
2015-01-13T15:03:39.979 INFO:tasks.workunit.client.0.vpm104.stderr: 19: (()+0x79d1) [0x7fb35e51f9d1]
2015-01-13T15:03:39.979 INFO:tasks.workunit.client.0.vpm104.stderr: 20: (clone()+0x6d) [0x7fb35db4c86d]

Related issues

Duplicates Ceph - Bug #10399: kvm die with assert(m_seed < old_pg_num) Resolved 12/19/2014
Duplicates Ceph - Bug #10430: osd/osd_types.cc: 456: FAILED assert(m_seed < old_pg_num) Resolved 12/23/2014

History

#1 Updated by Yuri Weinstein over 5 years ago

Same problem in http://pulpito.ceph.com/teuthology-2015-01-13_17:05:01-upgrade:giant-x-next-distro-basic-vps/

Jobs ['701575', '701576', '701582']

Assertion: osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
ceph version 0.87-77-g16c023d (16c023d8fa5575d4dd138aeee4d4fd9b8f32c0f6)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0x7f7a13b2d4cb]
 2: (()+0x36f641) [0x7f7a13bee641]
 3: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0xcd) [0x7f7a13bee71d]
 4: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x7e9) [0x7f7a13a9fd09]
 5: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x45) [0x7f7a13ab2de5]
 6: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x21a) [0x7f7a13ab360a]
 7: (Objecter::handle_osd_map(MOSDMap*)+0x6f2) [0x7f7a13ab59c2]
 8: (Objecter::ms_dispatch(Message*)+0x1df) [0x7f7a13abb57f]
 9: (DispatchQueue::entry()+0x649) [0x7f7a13c3b179]
 10: (DispatchQueue::DispatchThread::entry()+0xd) [0x7f7a13cb58ad]
 11: (()+0x8182) [0x7f7a18d42182]
 12: (clone()+0x6d) [0x7f7a18a6eefd]

#2 Updated by Yuri Weinstein over 5 years ago

  • Status changed from New to Duplicate

#3 Updated by Yuri Weinstein over 5 years ago

  • Status changed from Duplicate to New

Seeing in
run: http://pulpito.ceph.com/teuthology-2015-01-31_17:05:03-upgrade:giant-x-next-distro-basic-vps/
Job: 734064
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2015-01-31_17:05:03-upgrade:giant-x-next-distro-basic-vps/734064/

2015-01-31T17:44:24.836 INFO:tasks.workunit.client.0.vpm156.stderr:    -1> 2015-01-31 20:44:17.784716 7ff4a365b700  1 -- 10.214.140.111:0/1003689 <== mon.2 10.214.139.234:6791/0 79 ==== osd_map(167..168 src has 1..168) v3 ==== 651+0+0 (588487817 0 0) 0x7ff498001e70 con 0x804670
2015-01-31T17:44:24.836 INFO:tasks.workunit.client.0.vpm156.stderr:     0> 2015-01-31 20:44:23.217786 7ff4a365b700 -1 osd/osd_types.cc: In function 'bool pg_t::is_split(unsigned int, unsigned int, std::set<pg_t, std::less<pg_t>, std::allocator<pg_t> >*) const' thread 7ff4a365b700 time 2015-01-31 20:44:18.352296
2015-01-31T17:44:24.836 INFO:tasks.workunit.client.0.vpm156.stderr:osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
2015-01-31T17:44:24.836 INFO:tasks.workunit.client.0.vpm156.stderr:
2015-01-31T17:44:24.836 INFO:tasks.workunit.client.0.vpm156.stderr: ceph version 0.87-86-g1ccd73a (1ccd73a16e1829b5519ec5b83b2554af173ad052)
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 1: (()+0x34ab7d) [0x7ff4ab112b7d]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 2: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0x7a) [0x7ff4ab120f3a]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 3: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x91e) [0x7ff4ad6017ee]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 4: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x6a) [0x7ff4ad601d6a]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 5: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x22c) [0x7ff4ad60940c]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 6: (Objecter::handle_osd_map(MOSDMap*)+0xe47) [0x7ff4ad618517]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 7: (Objecter::ms_dispatch(Message*)+0x26b) [0x7ff4ad61986b]
2015-01-31T17:44:24.837 INFO:tasks.workunit.client.0.vpm156.stderr: 8: (DispatchQueue::entry()+0x4fa) [0x7ff4ab198fea]
2015-01-31T17:44:24.838 INFO:tasks.workunit.client.0.vpm156.stderr: 9: (DispatchQueue::DispatchThread::entry()+0xd) [0x7ff4ab17800d]
2015-01-31T17:44:24.838 INFO:tasks.workunit.client.0.vpm156.stderr: 10: (()+0x79d1) [0x7ff4aabb29d1]
2015-01-31T17:44:24.838 INFO:tasks.workunit.client.0.vpm156.stderr: 11: (clone()+0x6d) [0x7ff4aa1df86d]
2015-01-31T17:44:24.838 INFO:tasks.workunit.client.0.vpm156.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

#4 Updated by Sage Weil over 5 years ago

  • Status changed from New to Can't reproduce

#5 Updated by Yuri Weinstein over 5 years ago

  • Status changed from Can't reproduce to New

Once again in
Run: http://pulpito.ceph.com/teuthology-2015-03-14_17:05:02-upgrade:giant-x-hammer-distro-basic-vps/
Job: ['804129']
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2015-03-14_17:05:02-upgrade:giant-x-hammer-distro-basic-vps/804129/

015-03-15T04:18:04.883 INFO:tasks.thrashosds.thrasher:choose_action: min_in 3 min_out 0 min_live 2 min_dead 0
2015-03-15T04:18:04.883 INFO:tasks.thrashosds.thrasher:Growing pool rbd
2015-03-15T04:18:04.883 INFO:teuthology.orchestra.run.vpm154:Running: 'adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage ceph pg dump --format=json'
2015-03-15T04:18:06.033 INFO:teuthology.orchestra.run.vpm154.stderr:dumped all in format json
2015-03-15T04:18:06.062 INFO:tasks.ceph.ceph_manager:increase pool size by 10
2015-03-15T04:18:06.062 INFO:teuthology.orchestra.run.vpm154:Running: 'adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage ceph osd pool set rbd pg_num 66'
2015-03-15T04:18:07.387 INFO:teuthology.orchestra.run.vpm154.stderr:set pool 0 pg_num to 66
2015-03-15T04:18:07.400 INFO:tasks.workunit.client.0.vpm097.stderr:osd/osd_types.cc: In function 'bool pg_t::is_split(unsigned int, unsigned int, std::set<pg_t, std::less<pg_t>, std::allocator<pg_t> >*) const' thread 7f3dafe6b700 time 2015-03-15 07:18:07.331724
2015-03-15T04:18:07.400 INFO:tasks.workunit.client.0.vpm097.stderr:osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
2015-03-15T04:18:07.418 INFO:tasks.workunit.client.0.vpm097.stderr: ceph version 0.87.1-1-g938e036 (938e03630e075af03780da139ae879b5b0377734)
2015-03-15T04:18:07.419 INFO:tasks.workunit.client.0.vpm097.stderr: 1: (()+0x34b12d) [0x7f3db78f912d]
2015-03-15T04:18:07.419 INFO:tasks.workunit.client.0.vpm097.stderr: 2: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0x7a) [0x7f3db79074ea]
2015-03-15T04:18:07.419 INFO:tasks.workunit.client.0.vpm097.stderr: 3: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x91e) [0x7f3db9de80ee]
2015-03-15T04:18:07.419 INFO:tasks.workunit.client.0.vpm097.stderr: 4: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x6a) [0x7f3db9de866a]
2015-03-15T04:18:07.420 INFO:tasks.workunit.client.0.vpm097.stderr: 5: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x22c) [0x7f3db9defcfc]
2015-03-15T04:18:07.420 INFO:tasks.workunit.client.0.vpm097.stderr: 6: (Objecter::handle_osd_map(MOSDMap*)+0xe47) [0x7f3db9dfee27]
2015-03-15T04:18:07.420 INFO:tasks.workunit.client.0.vpm097.stderr: 7: (Objecter::ms_dispatch(Message*)+0x26b) [0x7f3db9e0017b]
2015-03-15T04:18:07.421 INFO:tasks.workunit.client.0.vpm097.stderr: 8: (DispatchQueue::entry()+0x4fa) [0x7f3db79adefa]
2015-03-15T04:18:07.421 INFO:tasks.workunit.client.0.vpm097.stderr: 9: (DispatchQueue::DispatchThread::entry()+0xd) [0x7f3db79a911d]
2015-03-15T04:18:07.421 INFO:tasks.workunit.client.0.vpm097.stderr: 10: (()+0x7851) [0x7f3db7398851]
2015-03-15T04:18:07.421 INFO:tasks.workunit.client.0.vpm097.stderr: 11: (clone()+0x6d) [0x7f3db69c690d]
2015-03-15T04:18:07.422 INFO:tasks.workunit.client.0.vpm097.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

#6 Updated by Samuel Just over 5 years ago

  • Priority changed from Normal to Urgent

#7 Updated by Samuel Just over 5 years ago

  • Priority changed from Urgent to High

#8 Updated by Loic Dachary over 5 years ago

  • Status changed from New to Duplicate
  • Priority changed from High to Urgent

#9 Updated by Loic Dachary over 5 years ago

duplicate of http://tracker.ceph.com/issues/10430 that needs backporting

#10 Updated by Yuri Weinstein about 5 years ago

  • Regression set to No
  • Release set to hammer
  • ceph-qa-suite upgrade/giant-x added

Run: http://pulpito.ceph.com/teuthology-2015-07-20_17:05:10-upgrade:giant-x-hammer-distro-basic-vps/
Jobs: 980983
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2015-07-20_17:05:10-upgrade:giant-x-hammer-distro-basic-vps/980983/teuthology.log

2015-07-20T20:16:13.101 INFO:teuthology.orchestra.run.vpm138.stderr:set pool 0 pg_num to 66
2015-07-20T20:16:13.132 INFO:tasks.workunit.client.0.vpm044.stderr:osd/osd_types.cc: In function 'bool pg_t::is_split(unsigned int, unsigned int, std::set<pg_t>*) const' thread 7fead0608700 time 2015-07-21 03:16:13.091761
2015-07-20T20:16:13.132 INFO:tasks.workunit.client.0.vpm044.stderr:osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
2015-07-20T20:16:13.167 INFO:tasks.workunit.client.0.vpm044.stderr: ceph version 0.87.2-8-g6c33a35 (6c33a35f854ff7399bec12830d27aac56ce1508b)
2015-07-20T20:16:13.167 INFO:tasks.workunit.client.0.vpm044.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x7f) [0x7fead533ae0f]
2015-07-20T20:16:13.167 INFO:tasks.workunit.client.0.vpm044.stderr: 2: (()+0x310232) [0x7fead53ff232]
2015-07-20T20:16:13.168 INFO:tasks.workunit.client.0.vpm044.stderr: 3: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0xe4) [0x7fead53ff324]
2015-07-20T20:16:13.168 INFO:tasks.workunit.client.0.vpm044.stderr: 4: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x965) [0x7fead7776035]
2015-07-20T20:16:13.168 INFO:tasks.workunit.client.0.vpm044.stderr: 5: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x59) [0x7fead7784cc9]
2015-07-20T20:16:13.168 INFO:tasks.workunit.client.0.vpm044.stderr: 6: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x1cf) [0x7fead77850df]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 7: (Objecter::handle_osd_map(MOSDMap*)+0x5f6) [0x7fead778b8a6]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 8: (Objecter::ms_dispatch(Message*)+0x257) [0x7fead7791dd7]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 9: (Messenger::ms_deliver_dispatch(Message*)+0x77) [0x7fead544c1d7]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 10: (DispatchQueue::entry()+0x44a) [0x7fead544937a]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 11: (DispatchQueue::DispatchThread::entry()+0xd) [0x7fead54bfccd]
2015-07-20T20:16:13.169 INFO:tasks.workunit.client.0.vpm044.stderr: 12: (()+0x7e9a) [0x7fead4ed9e9a]
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr: 13: (clone()+0x6d) [0x7fead44ec38d]
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr:2015-07-21 03:16:13.152335 7fead0608700 -1 osd/osd_types.cc: In function 'bool pg_t::is_split(unsigned int, unsigned int, std::set<pg_t>*) const' thread 7fead0608700 time 2015-07-21 03:16:13.091761
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr:osd/osd_types.cc: 411: FAILED assert(m_seed < old_pg_num)
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr:
2015-07-20T20:16:13.170 INFO:tasks.workunit.client.0.vpm044.stderr: ceph version 0.87.2-8-g6c33a35 (6c33a35f854ff7399bec12830d27aac56ce1508b)
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x7f) [0x7fead533ae0f]
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 2: (()+0x310232) [0x7fead53ff232]
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 3: (pg_interval_t::is_new_interval(int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, std::vector<int, std::allocator<int> > const&, std::vector<int, std::allocator<int> > const&, int, int, unsigned int, unsigned int, pg_t)+0xe4) [0x7fead53ff324]
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 4: (Objecter::_calc_target(Objecter::op_target_t*, bool)+0x965) [0x7fead7776035]
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 5: (Objecter::_recalc_linger_op_target(Objecter::LingerOp*, RWLock::Context&)+0x59) [0x7fead7784cc9]
2015-07-20T20:16:13.171 INFO:tasks.workunit.client.0.vpm044.stderr: 6: (Objecter::_scan_requests(Objecter::OSDSession*, bool, bool, std::map<unsigned long, Objecter::Op*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::Op*> > >&, std::list<Objecter::LingerOp*, std::allocator<Objecter::LingerOp*> >&, std::map<unsigned long, Objecter::CommandOp*, std::less<unsigned long>, std::allocator<std::pair<unsigned long const, Objecter::CommandOp*> > >&)+0x1cf) [0x7fead77850df]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 7: (Objecter::handle_osd_map(MOSDMap*)+0x5f6) [0x7fead778b8a6]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 8: (Objecter::ms_dispatch(Message*)+0x257) [0x7fead7791dd7]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 9: (Messenger::ms_deliver_dispatch(Message*)+0x77) [0x7fead544c1d7]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 10: (DispatchQueue::entry()+0x44a) [0x7fead544937a]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 11: (DispatchQueue::DispatchThread::entry()+0xd) [0x7fead54bfccd]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 12: (()+0x7e9a) [0x7fead4ed9e9a]
2015-07-20T20:16:13.172 INFO:tasks.workunit.client.0.vpm044.stderr: 13: (clone()+0x6d) [0x7fead44ec38d]
2015-07-20T20:16:13.173 INFO:tasks.workunit.client.0.vpm044.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this

#11 Updated by Yuri Weinstein about 5 years ago

  • Status changed from Duplicate to New

#12 Updated by Yuri Weinstein about 5 years ago

  • Subject changed from "FAILED assert(m_seed < old_pg_num)" in upgrade:giant-x-next-distro-basic-vps run to "FAILED assert(m_seed < old_pg_num)" in upgrade:giant-x-hammer-distro-basic-vps run

#13 Updated by Samuel Just almost 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF