Project

General

Profile

Bug #10520

RPM machines need to get iozone installed for teuthology

Added by Greg Farnum over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Sandon Van Ness
Category:
-
Target version:
-
Start date:
01/12/2015
Due date:
% Done:

100%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

See eg http://qa-proxy.ceph.com/teuthology/teuthology-2015-01-10_23:04:02-fs-next-testing-basic-multi/697056/

Apparently the RHEL-family stuff doesn't get iozone installed, but Ubuntu does. This causes test failures and is happening in both the magna and sepia labs.

History

#1 Updated by Ken Dreyer over 4 years ago

I was looking to see why iozone wasn't available for EPEL 7, and apparently it's non-free software: https://bugzilla.redhat.com/852901

#2 Updated by Ken Dreyer over 4 years ago

  • Status changed from New to Need Review

#3 Updated by Zack Cerza over 4 years ago

  • Assignee deleted (Sandon Van Ness)

After looking at the PR, it doesn't seem we've decided what to do about this

#4 Updated by Greg Farnum over 4 years ago

  • Status changed from Need Review to Verified
  • Assignee set to Sandon Van Ness

Packages are available in either the RHEL7 DAG (?whatever that is) or at http://www.iozone.org/src/current/. Let's please draw from one of those sources to get our tests working unless there's something else preventing it.

#5 Updated by Sandon Van Ness over 4 years ago

Ok, so we want iozone and we aren't dropping it? The only reason this wasn't completed yet is it appeared we were potentially dropping the tests but if the decision has been reached I am happy to get that package on our lab machines. If a src rpm is available I can probalby just put it into my jenkins rebuild script that will rebuild it on all our various dists (rhel/centos/fedora on the various versions) unless we really just want this on rhel7 and nothing else.

#6 Updated by Greg Farnum over 4 years ago

Yeah, we could probably replace iozone if we had to but it would take a fair bit of work to avoid losing test coverage, and just because it's non-free doesn't seem like a good reason to ditch them (unlike tiobench, which isn't being maintained). Since there are packages available for download I think we should just use them. :)

#7 Updated by Sandon Van Ness over 4 years ago

  • Status changed from Verified to Resolved
  • % Done changed from 0 to 100

Built out own iozone and pushed to a new 'lab-extras' repo and modified ceph-qa-chef to install this on our rhel/centos 6/7 machines/vms.

Also available in: Atom PDF