Project

General

Profile

Bug #10497

librados: c api does not translate op flag

Added by Josh Durgin over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
librados
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
giant, firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This means the flags aren't passed to rados as intended, and don't work through the C api.

Fixed in master by https://github.com/ceph/ceph/pull/3324 this is to track backports.

49d114f1fff90e5c0f206725a5eb82c0ba329376

History

#1 Updated by Loïc Dachary over 6 years ago

  • Description updated (diff)

#2 Updated by Loïc Dachary over 6 years ago

  • Description updated (diff)

#5 Updated by Loïc Dachary about 6 years ago

fc43d8c librados: Translate operation flags from C APIs (in giant), a22aa8f librados: Translate operation flags from C APIs (in firefly),

#6 Updated by Loïc Dachary about 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF