Project

General

Profile

Bug #10465

Audit and fix ceph-qa-suite exec tasks

Added by Greg Farnum over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Testing
Target version:
-
Start date:
01/06/2015
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

suites/fs/basic/tasks/cfuse_workunit_suites_truncate_delay.yaml executes a dd and a truncate on a file in the local node's regular filesystem, rather than in the ceph-fuse mountpoint. That means we haven't gotten all the truncate coverage we think we do!

Audit the other uses of the "exec" task for similar issues and fix any that arise.

Associated revisions

Revision 8a5f76d1 (diff)
Added by Greg Farnum over 4 years ago

fs: move into the ceph-fuse mount before doing a test

Fixes: #10465

Signed-off-by: Greg Farnum <>

Revision 2a28b7a6 (diff)
Added by Greg Farnum over 4 years ago

fs: move into the ceph-fuse mount before doing a test

Fixes: #10465

Signed-off-by: Greg Farnum <>
(cherry picked from commit 8a5f76d10bc8bf0358f5215ac2aadfb210691507)

History

#1 Updated by Greg Farnum over 4 years ago

Also, I noticed this because http://qa-proxy.ceph.com/teuthology/teuthology-2014-12-26_23:04:02-fs-master-testing-basic-multi/680701/ failed while executing that, which also doesn't make any sense?

#2 Updated by Greg Farnum over 4 years ago

  • Priority changed from High to Urgent

#3 Updated by Greg Farnum over 4 years ago

  • Category set to Testing
  • Status changed from Verified to Testing
  • Assignee set to Greg Farnum
  • Priority changed from Urgent to Normal

commit:8a5f76d10bc8bf0358f5215ac2aadfb210691507 in master fixes the dd location; there were no other yaml fragments putting stuff in the wrong place. Assuming that doesn't turn up any problems we'll want to backport it.

I also looked briefly at the actual test failure again, but there just isn't much to go on and it passes the overwhelming majority of the time, so either it's some weird transient issue or something to do with which machine/OS combo we're using that we'll need to see again before I decide to spend any time on it.

#4 Updated by Greg Farnum over 4 years ago

  • Status changed from Testing to Resolved

Master branch has been tested several times since this went in, so I backported it to giant,firefly,dumpling qa suites.

Also available in: Atom PDF