Project

General

Profile

Bug #10456

Calamari client hard codes ceph as cluster name in DiskSpaceTargets.ejs

Added by Anthony Alba over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Category:
UI
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

1. calamari-clients branch v1,3, master
2. if the cluster name is customized (i.e. not ceph), then
Graph -> Host - XX -> Disk -> Capacity/Inodes is always empty

How reproducible: always

Steps:
1. create Ceph cluster with non-standard name
2. create calamari instance
3. view Disk -> Capacity/Inodes panel

Cause:
The js UI is rendering the metric
servers.<%- hostname >.diskspace._var_lib_ceph_osd_ceph-<- id >.<- metric %>

but Diamond on the client is actually sending
servers.<%- hostname >.diskspace._var_lib_ceph_osd_<- customClusterName >< id >.<- metric %>

Is there a template directive for the cluster name?

In the source code, there is <%- clusterName -> which seems to be the UUID not the cluster name

Associated revisions

Revision 09e76742 (diff)
Added by Kanagaraj Mayilsamy over 6 years ago

substitute cluster-name in disk space graph

In disk space graph, cluster name was hardcoded to 'ceph'.
So when the cluster name is different the graph is not shown
as the graphite parameters are wrongly generated.

This is now fixied by substituting the cluster name
in the disk-space graph template.

Fixes: #10456
Signed-off-by: Kanagaraj M <>

History

#2 Updated by Dan Mick over 6 years ago

  • Category set to UI
  • Source changed from other to Community (user)

#3 Updated by Anthony Alba over 6 years ago

On the instance, I modified the cluster name

webapp/content/dashboard/scripts/main.js

sed -i -e 's/var_lib_ceph_osd_ceph/var_lib_ceph_osd_MYCLUSTERNAME/g' main.js

and this seemed to fix the problem.

#4 Updated by Kanagaraj Mayilsamy over 6 years ago

  • Assignee set to Kanagaraj Mayilsamy

#5 Updated by Kanagaraj Mayilsamy over 6 years ago

  • Status changed from New to Fix Under Review

#6 Updated by Christina Meno over 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF