Project

General

Profile

Bug #10179

calamari-clients: calculatePGNum could create issues

Added by Alexandre Marangone about 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

When creating a new pool, Calamari suggests a pg_num value according to:
pgnum = roundUpToNextPowerOfTwo(osdcount * 100 / size)

This formula should be used to define the number of placement groups that will be distributed across all pools in the cluster, not a per-pool value.

Too many PGs in a cluster could result in serious issues.

History

#1 Updated by Dan Mick about 6 years ago

  • Status changed from New to Need More Info

Suggestions for a better formula for a recommendation?

#2 Updated by Alexandre Marangone about 6 years ago

I don't think there's a perfect solution since it depends on the number of pools already present and the number of pools the user wants to create.
One way to go would be to defer this to the user by adding a help button (like on the graphs page), linking to our documentation on PGs (which needs to be updated too, see #9867).

#3 Updated by John Spray about 6 years ago

One fairly lightweight thing to do here would be to work out (before submission) if the input value would cause the mon_pg_warn_[min|max]_per_osd thresholds to be violated (the max one will be new in hammer I think).

#4 Updated by Dan Mick about 6 years ago

  • Assignee set to Gregory Meno

#5 Updated by Alexandre Marangone over 2 years ago

  • Status changed from Need More Info to Closed

Also available in: Atom PDF