Project

General

Profile

Bug #10132

osd: tries to set ioprio when the config option is blank

Added by Greg Farnum almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
-
Start date:
11/18/2014
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Saw this in a log:

Nov 12 18:53:41 s4 systemd-docker[2718]: 2014-11-12 18:53:41.370534 7f06e954d800 -1 osd.13 459364 set_disk_tp_priority(22) Invalid argument: osd_disk_thread_ioprio_class is  but only the following values are allowed: idle, be or rt

It looks like the config option defaults to an empty string, so I assume the OSD code is just making the syscall or whatever unconditionally.

History

#2 Updated by Sage Weil over 4 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF