Project

General

Profile

Bug #10093

ceph-monstore-tool: FAILED assert(!is_open)

Added by Loïc Dachary about 8 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Monitor
Target version:
-
% Done:

100%

Source:
other
Tags:
Backport:
hammer
Regression:
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Using a vstart cluster + stoph.sh:

$ ./ceph-monstore-tool --mon-store-path dev/mon.a --out /tmp/m --command getosdmap
...
./mon/MonitorDBStore.h: 630: FAILED assert(!is_open)

 ceph version 0.88-250-g5ce0919 (5ce09198bf475e5c3a2df26232fa04ba9912b103)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x95) [0x85377f]
 2: (MonitorDBStore::~MonitorDBStore()+0x35) [0x82b565]
 3: (main()+0x2102) [0x825db7]
 4: (__libc_start_main()+0xf5) [0x7ff0341beec5]
 5: ./ceph-monstore-tool() [0x823939]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.


Related issues

Copied to Ceph - Backport #14497: hammer: ceph-monstore-tool: FAILED assert(!is_open) Resolved

Associated revisions

Revision 1cd7422a (diff)
Added by Loic Dachary about 8 years ago

mon: ceph-monstore-tool must close()

Otherwise it asserts because the destructor checks for the is_open flag.

http://tracker.ceph.com/issues/10093 Fixes: #10093

Signed-off-by: Loic Dachary <>

History

#1 Updated by Loïc Dachary about 8 years ago

  • Status changed from 12 to Fix Under Review
  • % Done changed from 0 to 80

#2 Updated by Joao Eduardo Luis about 8 years ago

  • Status changed from Fix Under Review to Resolved

#3 Updated by Loïc Dachary about 8 years ago

  • % Done changed from 80 to 100

#4 Updated by Loïc Dachary over 7 years ago

see also a more recent manifestation fixed at https://github.com/ceph/ceph/pull/4411

#5 Updated by Kefu Chai almost 7 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to hammer

#6 Updated by Kefu Chai almost 7 years ago

  • Copied to Backport #14497: hammer: ceph-monstore-tool: FAILED assert(!is_open) added

#7 Updated by Nathan Cutler almost 7 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF