Project

General

Profile

Bug #971

OSD's write pid to /var/run/ceph/$type.$id.pid

Added by Wido den Hollander about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
-
Start date:
04/04/2011
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

It seems that 9cde1f44a57cd630a66e77ed3d59127d91834d09 has broken the writing of pidfiles for OSD's, but it could also due to 6966c3eda74064e766e22c21203ea30f97910f32

My MON and MDS write their pid fine, but the OSD's don't:

root@atom0:~# ls /var/run/ceph/
$type.$id.pid
root@atom0:~#

ceph.conf View (4.47 KB) Wido den Hollander, 04/04/2011 10:30 AM

History

#1 Updated by Sage Weil about 8 years ago

  • Assignee set to Colin McCabe

Colin, can you verify whether this affects 0.26 too before I tag that release today? Thanks!

#2 Updated by Colin McCabe about 8 years ago

This doesn't occur for me at change 6966c3eda74064e766e22c21203ea30f97910f32. It is not in 0.26.

#3 Updated by Colin McCabe about 8 years ago

I'm afraid I'm not able to reproduce this in master. Can you try again with head-of-line and see if it is fixed there?

If that doesn't work, then I guess we need to look at the config file that you're using.

Colin

#4 Updated by Wido den Hollander about 8 years ago

Just tried with d94142221153ec985c699ad69c3925136f3a30de still the same result.

My ceph.conf is attached

#5 Updated by Colin McCabe about 8 years ago

I think I know what's going on here. Will fix in a little bit.

#6 Updated by Colin McCabe about 8 years ago

  • Status changed from New to Testing

#7 Updated by Wido den Hollander about 8 years ago

Yes, that works for me. PID's are correct now.

#9 Updated by Colin McCabe about 8 years ago

  • Status changed from Testing to Resolved

confirmed fixed.
cconf is fixed too.

Also available in: Atom PDF