Project

General

Profile

Feature #8911

RGW doesn't return 'x-timestamp' in header which is used by 'View Details' of OpenStack

Added by Michael Kidd over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
Start date:
07/23/2014
Due date:
% Done:

0%

Source:
Support
Tags:
Backport:
giant, firefly
Reviewed:
Affected Versions:
Pull request ID:

Description

Because RGW doesn't provide an 'x-timestamp' header in its reply to OpenStack, the 'View Details' feature fails as noted below.

Horizon bug:
https://bugs.launchpad.net/horizon/+bug/1297173

Proposed Horizon patch (abandoned):
https://review.openstack.org/#/c/82801/

Steps to reproduce:

With Ceph configured as the Object Storage backend,

Navigate to Object Store - > Containers.
Click on a Container in the list of containers.
For an Object in In the Objects panel, Click on More -> View Details.

Expected Result:
Details of object should be displayed in a pop-up modal.

Actual Result:
An Error pop-up appears with the text " Error: An error occurred. Please try again later."


Related issues

Copied to rgw - Backport #11717: RGW doesn't return 'x-timestamp' in header which is used by 'View Details' of OpenStack Resolved 07/23/2014
Copied to rgw - Backport #11718: RGW doesn't return 'x-timestamp' in header which is used by 'View Details' of OpenStack Resolved 07/23/2014

Associated revisions

Revision 5b41d80b (diff)
Added by Yehuda Sadeh about 4 years ago

rgw: swift GET / HEAD object returns X-Timestamp field

Fixes: #8911
Backport: giant, firefly, dumpling
Swift clients expect X-Timestamp header, dump it.

Signed-off-by: Yehuda Sadeh <>

Revision e230fabf (diff)
Added by Yehuda Sadeh almost 4 years ago

rgw: swift GET / HEAD object returns X-Timestamp field

Fixes: #8911
Backport: giant, firefly, dumpling
Swift clients expect X-Timestamp header, dump it.

Signed-off-by: Yehuda Sadeh <>
(cherry picked from commit 5b41d80b7fb9ed96c26801fc42c044191bb18d84)

Revision 8c573c88 (diff)
Added by Yehuda Sadeh over 3 years ago

rgw: swift GET / HEAD object returns X-Timestamp field

Fixes: #8911
Backport: giant, firefly, dumpling
Swift clients expect X-Timestamp header, dump it.

Signed-off-by: Yehuda Sadeh <>
(cherry picked from commit 5b41d80b7fb9ed96c26801fc42c044191bb18d84)

History

#1 Updated by Michael Kidd over 4 years ago

Just to be clear, Swift does return this header and the OpenStack devs advise they only test against the Swift storage backend.

#2 Updated by Sage Weil over 4 years ago

  • Priority changed from Normal to High

#3 Updated by Ashish Chandra over 4 years ago

It also doesnot returns "Content-type" header as well. Swift does return this header aswell. So I would love to see radosgw returning these two headers.

#4 Updated by Sage Weil over 4 years ago

  • Assignee set to Luis Pabon

#5 Updated by Luis Pabon about 4 years ago

I'll take a look. Seems like this is new functionality in RGW, not a bug, right?

#6 Updated by Ashish Chandra about 4 years ago

Thanks Luis... actually its a new feature request not a bug. Since we want one to one headers mapping between Swift and Ceph RadosGW, mising headers does causes issues.

#7 Updated by Ian Colle about 4 years ago

  • Tracker changed from Bug to Feature

#8 Updated by Michael Kidd about 4 years ago

Hello Luis, et al..
I have a customer who's requesting status for this Feature.. They view it as a bug since it causes interop issues w/ OpenStack Havana...

Thanks for any details you can provide...

#9 Updated by Ian Colle about 4 years ago

  • Status changed from New to In Progress

#10 Updated by Sage Weil about 4 years ago

  • Status changed from In Progress to Pending Backport
  • Backport set to giant, firefly

#11 Updated by Loic Dachary almost 4 years ago

  • Status changed from Pending Backport to Resolved

#12 Updated by Loic Dachary over 3 years ago

  • Status changed from Resolved to Pending Backport

it looks like this has not been backport to firefly after all...

#14 Updated by Nathan Cutler over 3 years ago

Has already been merged into giant:

commit:e230fab rgw: swift GET / HEAD object returns X-Timestamp field (in  giant)

#15 Updated by Nathan Cutler over 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF