Project

General

Profile

Bug #6726

Official packages do not appear to be available for Saucy

Added by Mark Nelson over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Sandon Van Ness
Category:
-
Target version:
-
Start date:
11/06/2013
Due date:
% Done:

100%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Release:
Needs Doc:
No

Description

It appears we are missing saucy packages here:

http://ceph.com/debian-emperor/dists/

But we do have them in the gitbuilder repos.

Mark

History

#1 Updated by Mark Nelson over 3 years ago

This appears to be the case for dumpling as well.

#2 Updated by Peter Matulis over 3 years ago

I suggest seeing this in a more general way. Was this merely an oversight or is the current workflow lacking in some way? That is, we don't want to file another such bug for the next Ubuntu release.

#3 Updated by Graeme Nordgren over 3 years ago

Mark filed this for me based on a conversation on IRC. It was pointed out that the latest packages current exist in the official Ubuntu repo, but for automation purposes, it's important to have packages for all distro releases present in this official repo. This allows automation tooling in puppet/salt/chef/etc to install this repo by default, and not worry about what is or isn't present in distro supplied repos.

#4 Updated by Graeme Nordgren over 3 years ago

This is even more important now that 0.72 (emperor) packages are available in the repo for previous releases, but not for saucy.

#5 Updated by Greg Farnum over 3 years ago

  • Assignee set to Anonymous

Is there something blocking this, or just have to get to it? :)

#6 Updated by Graeme Nordgren over 3 years ago

Conversation I had with Mark and Peter on IRC seemed to indicate it had just been overlooked, since the packages are in gitbuilder.

#7 Updated by Tom Voss over 3 years ago

Since this has been brought to Mark and Peter's attention, is this going to be remedied any time soon? In the meantime, if anyone has a workaround to get ceph-deploy to work with Ubuntu Saucy I'd love to learn it.

#8 Updated by Tom Verdaat over 3 years ago

+1 of the previous question!

I get the impression from comment #6 that this would be easy to fix. Any chance that this hasn't happened yet because it's assigned to Gary Lowell who has (according to the site) last visited on 10-12-2013? If so can somebody alert him or reassign the ticket to somebody else that would be able to handle it?

Thanks!

#9 Updated by Michael Potter about 3 years ago

Just had a suggestion to use the raring packages from Tim Bishop on the users list.

Would be nice if we could get this looked into, Trusty (The next LTR) is now feature frozen and speeding towards release so a fair few people will probably be looking to start testing it for deployment over the next couple of months.

#10 Updated by Ian Colle about 3 years ago

  • Assignee changed from Anonymous to Sandon Van Ness

We are currently building on both Saucy and Trusty, just need to push packages out to ceph.com

See
http://gitbuilder.ceph.com/ceph-deb-trusty-x86_64-basic/
http://gitbuilder.ceph.com/ceph-deb-saucy-x86_64-basic/

#11 Updated by Sandon Van Ness about 3 years ago

Ok, i was able to sucessfully build for saucy on jenkins. Trusty is giving me trouble as the machines I was using are lxc containers which don't work right with pbuilder. I will probably need to get a new baremetal pbuilder slave setup for trusty.

#12 Updated by Sandon Van Ness about 3 years ago

Builds take quite a while and we are actually doing a release today so at the very least this will need to wait until the weekend. Of cours customers can always pull version branches from our gitbuilders as well but the point of this is to include it automatically for our ceph.com release builds. Should be able to build a few over thwe weekend and push to the repos on ceph.com. Do we need more than the newest available in dumpling/emperor?

The newest release we did today will include saucy.

#13 Updated by Tom Verdaat about 3 years ago

Been waiting for a while, one more weekend won't hurt ;)

Don't know about the others but I'll be very happy with emperor on saucy.

Thanks!

#14 Updated by Peter Matulis about 3 years ago

I propose the following:

1. Ubuntu LTS (12.04, 14.04, etc) can (should) stop at the Inktank-supported Ceph release for that version of Ubuntu. For 12.04 that means Dumpling and for 14.04 that means Firefly. It just so happens that 14.04 will ship with Firefly this time around (well 0.78 but updated to 0.80 later).

2. Ubuntu non-LTS (13.10, 14.10, etc) should have the last two most recent Ceph releases. For 13.10 that means Dumpling and Emperor and for 14.10 that means Firefly and Giant.

#15 Updated by Tom Verdaat about 3 years ago

Any progress on this bug Sandon?

#16 Updated by Sandon Van Ness about 3 years ago

All new releases are being built for trusty/saucy. It is not super high priority at the moment to rebuild all our older releases with trusty/saucy but it will happen.

#17 Updated by Tom Verdaat about 3 years ago

I understand but that's not the issue. They have always been built, but the problem is that they are not being published in the official Ceph deb repository. Can you make sure they get pushed?

#18 Updated by Sandon Van Ness about 3 years ago

There might be some confusion here. We have 'gitbuilders' that yes have been building them for some time that do nightly builds. Our release builds are done via a completely different infrastructure and its not just a matter of pushing our autobuild-ceph builds to the release repo. That is not how we do release builds.

Since this ticket was opened our release build has been changed to include saucy/trusty so any new releases will be pushed out to the ceph.com site as all of those files are done using our release build architecture.

#19 Updated by Tim Bishop about 3 years ago

Sandon Van Ness wrote:

Since this ticket was opened our release build has been changed to include saucy/trusty so any new releases will be pushed out to the ceph.com site as all of those files are done using our release build architecture.

So why are there no saucy/trusty packages for 0.79?

http://www.ceph.com/debian-testing/pool/main/c/ceph/

#20 Updated by Sandon Van Ness about 3 years ago

There should be as saucy/trusty was built for that release as I was involved with it today. I will find out what happened and why its not on the repo tomorrow.

#21 Updated by Sandon Van Ness about 3 years ago

There was a problem with our repo generator script for release builds which was causing even the new releases to not include saucy/trusty. This has now been fixed and the packages exist in debian-testing for saucy/trusty and should be included in any future release builds.

#22 Updated by Lauri Vant about 3 years ago

Sandon Van Ness wrote:

There was a problem with our repo generator script for release builds which was causing even the new releases to not include saucy/trusty. This has now been fixed and the packages exist in debian-testing for saucy/trusty and should be included in any future release builds.

Running ceph-deploy on a new Trusy node results in:
[ceph7][WARNIN] W: Failed to fetch http://ceph.com/debian-emperor/dists/trusty/main/binary-amd64/Packages 404 Not Found

When can we expect this to be resolved?

#23 Updated by Tom Verdaat about 3 years ago

Lauri Vant wrote:

When can we expect this to be resolved?

Based on my understanding of Sandon's replies above: when 0.80 is released. Existing releases are/will not packaged for Saucy and Trusty. New releases will be and 0.80 is the next on the schedule. Until then you'll have to use the packages available in the Ubuntu repository in stead of the Ceph repository.

#24 Updated by Peter Matulis about 3 years ago

Note that the Trusty Ubuntu archive will contain 0.80 (it already contains 0.79) once it's released by Inktank.

#25 Updated by Lauri Vant about 3 years ago

Tom Verdaat wrote:

Lauri Vant wrote:

When can we expect this to be resolved?

Based on my understanding of Sandon's replies above: when 0.80 is released. Existing releases are/will not packaged for Saucy and Trusty. New releases will be and 0.80 is the next on the schedule. Until then you'll have to use the packages available in the Ubuntu repository in stead of the Ceph repository.

Thank you.

I am aware that this is not a place for asking advice, but for the time bei it would be great if someone more knowledgeable would post a workaround on how to trick ceph-deploy rely on Ubuntu's repos. At the moment any "cepy-deploy new" command will fail as it will try to add this to the sources:
http://ceph.com/debian-emperor/dists/trusty/main/binary-amd64/Packages

#26 Updated by Sandon Van Ness almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Closing this out. We now have builds of dumpling, emperor, firefly and testing with saucy/trusty builds.

Also available in: Atom PDF