Project

General

Profile

Bug #657

nfs-reexport null deref in ceph_init_dentry

Added by Sage Weil over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
12/17/2010
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Al Viro observes:

        * ceph: nfs export code is fucked and AFAICT untested - the first
call of ceph_init_dentry() from ceph_fh_to_parent() that actually tries to
do anything (i.e. gets called on fh of directory outside of current dentry
tree) will blow up on attempt to dereference ->d_parent->d_inode.

Probably the d_op initialization should be moved to a different helper. We can do the d_op initialization in NFS reexport explicitly since it's always the live namespace (no snapshot reexport). And test!

History

#1 Updated by Sage Weil over 8 years ago

  • Assignee set to Sage Weil

fix was simpler than that.. commit:92cf765237e2787eb168096305c448caf25ac7f8

#2 Updated by Sage Weil over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF