Project

General

Profile

Bug #401

osd: avoid clone_obc, snapset_obc on replica pgs

Added by Sage Weil almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
Start date:
09/09/2010
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

This doesn't happen normally, since by default we ship the ObjectStore::Transaction over the wire. It can, though, and that code path clearly isn't being tested currently because we don't have obc's on the replica.

History

#1 Updated by Sage Weil almost 9 years ago

  • Status changed from New to Resolved
  • Target version changed from v0.21.3 to v0.22

The clone_obc is removed on the replicas by c25d9a46293c983aa888b0eb9ec5dcb0f69358bf. This is really just a cleanup.

We keep the snapset_obc, since some paths depend on ondisk state, and need to be cached, because the information isn't fed through from the primary.

Also available in: Atom PDF