Project

General

Profile

Bug #399

mon: trim laggy standby mdss from map

Added by Sage Weil over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Monitor
Target version:
Start date:
09/08/2010
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

On wido's cluster,

9701:   [2001:16f8:10:2::c3c3:3f9b]:6800/9588 '0' mds0.51 up:active seq 24685
5637:   :/0 '1' mds-1.0 up:standby seq 1 laggy since 10.08.10_18:57:23.000014
5659:   :/0 '1' mds-1.0 up:standby seq 1 laggy since 10.08.10_20:08:58.000500
9707:   [2001:16f8:10:2::c3c3:2e5c]:6800/7497 '1' mds-1.0 up:standby seq 1

Can we trim an up:standby machine when it's sufficiently laggy? We probably need to make sure it can add itself back again if it's removed from the mdsmap.

History

#1 Updated by Sage Weil over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF