Project

General

Profile

Bug #38122

Error ceph fs status

Added by Jos Collin 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

$ ./bin/ceph fs status myfs

and

$ ./bin/ceph fs status

shows:

*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
2019-01-31 16:33:41.782 7f5130c62700 -1 WARNING: all dangerous and experimental features are enabled.
2019-01-31 16:33:41.818 7f5130c62700 -1 WARNING: all dangerous and experimental features are enabled.
Error EINVAL: Traceback (most recent call last):
  File "/home/jcollin/workspace/ceph/src/pybind/mgr/mgr_module.py", line 829, in _handle_command
    r = getter(key, default)
  File "/home/jcollin/workspace/ceph/src/pybind/mgr/status/module.py", line 251, in handle_command
    return self.handle_fs_status(cmd)
  File "/home/jcollin/workspace/ceph/src/pybind/mgr/status/module.py", line 95, in handle_fs_status
    c_state = self.colorize(state, self.GREEN)
AttributeError: 'Module' object has no attribute 'colorize'


Related issues

Duplicated by mgr - Bug #38618: mgr/status: AttributeError: 'Module' object has no attribute 'colorize' Duplicate

History

#1 Updated by Patrick Donnelly 3 months ago

  • Project changed from fs to mgr
  • Category deleted (Administration/Usability)
  • Target version set to v14.0.0
  • Start date deleted (01/31/2019)

Looks like you're missing some python colorize package required by the ceph-mgr.

#2 Updated by Jos Collin 3 months ago

  • Status changed from New to Closed

@Patrick: Thanks. This is not a bug.

#3 Updated by Jos Collin about 1 month ago

  • Status changed from Closed to New

The problem is: install-deps.sh is not installing 'colorize' package in Fedora. Not sure which is the corresponding package in debian.

#4 Updated by Sebastian Wagner about 1 month ago

  • Pull request ID set to 26779

#5 Updated by Brad Hubbard about 1 month ago

  • Status changed from New to Need Review

#6 Updated by Patrick Donnelly about 1 month ago

  • Duplicated by Bug #38618: mgr/status: AttributeError: 'Module' object has no attribute 'colorize' added

#7 Updated by Sage Weil about 1 month ago

  • Status changed from Need Review to Resolved

#8 Updated by Patrick Donnelly 21 days ago

  • Duplicated by Bug #38996: cephfs-shell: ls command produces error: no "colorize" attribute found error added

#9 Updated by Patrick Donnelly 20 days ago

  • Duplicated by deleted (Bug #38996: cephfs-shell: ls command produces error: no "colorize" attribute found error)

Also available in: Atom PDF