Project

General

Profile

Bug #38094

mgr: crash list

Added by Ernesto Puerta 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/23/2017
Due date:
% Done:

69%

Source:
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

This is an issue to track Ceph Manager crashes and record as much information as possible.

As a criteria for classifying them a suggestion would be:
  • Signal. E.g.: Abort, Segmentation Fault
  • Thread involved. E.g.: mgr-fin, mgr-balancer
  • Lowest level named function involved (excluding Python specific ones). E.g.: ActivePyModules::get_python.

Subtasks

Bug #21891: ceph mgr stopping result in segfaultVerifiedChang Liu

Bug #37997: mgr: abort, dashboard, "recursive lock of PyModuleRegistry::lock"Resolved

Bug #38026: mgr: segfault, restful, PyModuleRunner::serve() > PyString_FromString() > PyObject_Malloc()Resolved

Bug #38047: mgr: segfault, dashboard, PyModule::get_typed_option_value > PyErr_RestoreNeed Review

Bug #38112: mgr: segfault, mgr-fin, ActivePyModules::get_python > PyFormatter::get > PyFormatter::finish_pending_streams > PyObject_MallocResolved

Bug #38113: mgr: segfault, mgr-fin, ActivePyModule::config_notify() > PyObject_Realloc > PyObject_Malloc: "mgr notify AttributeError: 'Module' object has no attribute 'True'"New

Bug #38114: mgr: segfault, mgr-fin, ActivePyModule::notify > PyObject_MallocNew

Bug #38123: mgr: segfault, dashboard, PyEval_EvalFrameEx()Resolved

Bug #38158: mgr: segfault in PGMapDigest::print_summary()Resolved

Bug #38204: mgr: segfault, prometheus, ActivePyModules::get_perf_schema_python > PyFormatter::dump_pyobjectResolved

Bug #38228: mgr: NO TRACE DUMP - "reap_dead start"Closed

Bug #38278: mgr: segfault, dashboard, PyModuleRunner::serve > PyString_FromStringAndSize > PyObject_MallocCan't reproduce

Bug #38292: mgr: abort, dashboard, tcmalloc::Log - after list_servers_pythonResolved

History

#1 Updated by Ernesto Puerta 6 months ago

  • Subject changed from Ceph Manager crash list to mgr: crash list
  • Description updated (diff)

#2 Updated by Sage Weil 5 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF