Project

General

Profile

Bug #38065

deep fsck fails on inspecting very large onodes

Added by Igor Fedotov 6 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/28/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Steps to reproduce (100%):
Put 3GB object to replicated pool via rados then do deep fsck either on mount or via ceph-bluestore-tool.
Following output is provided:

2019-01-28 17:17:55.960 7f5d42af2b40 -1 bdev(0x557b43254700 dev/osd0/block) aio_submit retries 5423
2019-01-28 17:17:57.836 7f5d42af2b40 -1 bluestore(dev/osd0) fsck error: #4:238134c4:::tmp_3g:head# error during read: (1073741824) Unknown error 1073741824


Related issues

Copied to bluestore - Backport #38187: mimic: deep fsck fails on inspecting very large onodes Resolved
Copied to bluestore - Backport #38188: luminous: deep fsck fails on inspecting very large onodes Resolved

History

#1 Updated by Igor Fedotov 6 months ago

Looks like aio_queue_t::submit_batch timeouts due to long list of blocks to read. We need to cap this for fsck and, probably, introduce a sort of throttling for regular reads...

#2 Updated by Igor Fedotov 6 months ago

  • Subject changed from deep fsck fails on inspecting objects >2Gb length to deep fsck fails on inspecting objects very large onodes

#3 Updated by Igor Fedotov 6 months ago

  • Subject changed from deep fsck fails on inspecting objects very large onodes to deep fsck fails on inspecting very large onodes

#5 Updated by Igor Fedotov 6 months ago

  • Status changed from New to Need Review

#6 Updated by Sage Weil 6 months ago

  • Backport set to mimic,luminous

#7 Updated by Yuri Weinstein 5 months ago

Igor Fedotov wrote:

https://github.com/ceph/ceph/pull/26170

merged

#8 Updated by Neha Ojha 5 months ago

  • Status changed from Need Review to Pending Backport

#9 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #38187: mimic: deep fsck fails on inspecting very large onodes added

#10 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #38188: luminous: deep fsck fails on inspecting very large onodes added

#11 Updated by Igor Fedotov 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF