Project

General

Profile

Bug #3768

perl is required for logrotate, we need to include Perl as a dependency

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
01/08/2013
Due date:
% Done:

0%

Spent time:
Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

logrotate for ceph (/etc/logrotate.d/ceph) uses perl commands
if perl is not installed, logrotate fails
if logrotate fails, the root filesystem fills up and the system fails.

So, we need to make sure that perl is set as a dependency upon ceph installation.

seeing this on a centos box, but logrotate is across all OS's, so we need to ensure that perl is available for all installs.

History

#1 Updated by Ian Colle over 6 years ago

  • Assignee set to Anonymous

#2 Updated by Sage Weil over 6 years ago

  • Priority changed from Normal to High

#3 Updated by Ian Colle over 6 years ago

  • Target version set to v0.57a

backport to bobtail

#4 Updated by Sam Lang over 6 years ago

I hate to see a dependency like perl get added for a oneliner perl regex. Is this the only place perl is used? Can we swap out that line for some read/sed scriptfoo instead?

#5 Updated by Anonymous over 6 years ago

Can we check to ensure perl is not used elsewhere?
Are there guidelines that are provided to the developers that specify that perl can not be used in the packaged code?

If those two are done, changing that line to something else would be fabulous. I hate to rely on the current perl package to be auto installed since it could change to a version that is not compatible with the line of code. not that it would be likely, but it would be possible.

#6 Updated by Anonymous over 6 years ago

The same issue exists with the debian packages. We have an explicit dependency on python, but not on perl. I don't see any other use of perl in system scripts, but we do have a bunch of ceph tools and utilities written in perl. It does not appear that they are packaged for installation.

#7 Updated by Anonymous over 6 years ago

  • Status changed from New to In Progress

#8 Updated by Greg Farnum over 6 years ago

  • Project changed from fs to Ceph
  • Target version deleted (v0.57a)

Whoops, this was never an FS bug. :)

#9 Updated by Anonymous over 6 years ago

  • Status changed from In Progress to Resolved

Branch: refs/heads/master
Home: https://github.com/ceph/ceph
Commit: bebdc70b4254a78d9fe86af9c645e828fd11e2b2
https://github.com/ceph/ceph/commit/bebdc70b4254a78d9fe86af9c645e828fd11e2b2
Author: Gary Lowell <>
Date: 2013-01-17 (Thu, 17 Jan 2013)

Changed paths:
M ceph.spec.in
M debian/control

Log Message:
-----------
build: Add perl installation dependency to rpm and debian packages.

There was already a dependency on python in the debian control file,
a similar dependency was added to the rpm spec file. perl is needed
for the logrotate script, so a dependecy was on perl wass added to
both. Bug 3768.

Signed-off-by: Gary Lowell <>

#10 Updated by Greg Farnum over 6 years ago

It had sounded to me like the trend was towards eliminating the Perl usage rather than adding it as a dependency. Did that turn out to be infeasible?

#11 Updated by Anonymous over 6 years ago

  • Status changed from Resolved to In Progress

Putting back to in-progress. The preferred solution is to replace the perl filter line with sed or python and remove the dependency on perl.

#12 Updated by Anonymous over 6 years ago

  • Status changed from In Progress to Need Review

#13 Updated by Sage Weil over 6 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF