Project

General

Profile

Bug #37665

ceph-objectstore-tool export from luminous, import to master clears same_interval_since

Added by Sage Weil 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
12/14/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

on luminous exporting osd.3, pg last seen as

2018-12-13 20:59:14.599607 7f4f03095700 10 osd.3 pg_epoch: 1220 pg[2.0( v 18'8 (0'0,18'8] local-lis/les=1208/1210 n=4 ec=15/15 lis/c 1208/1208 les/c/f 1210/1211/0 1208/1208/1208) [1,3] r=1 lpr=1208 luod=0'0 crt=18'8 active mbc={}] handle_peering_event: epoch_sent: 1220 epoch_requested: 1220 NullEvt

on master/nautilus importing osd.2, pg appears as
2018-12-13 21:01:05.686 7f74f69d98c0 10 osd.2 pg_epoch: 1220 pg[2.0( v 18'8 (0'0,18'8] local-lis/les=1208/1210 n=4 ec=15/15 lis/c 1208/1208 les/c/f 1210/1211/0 1208/0/1208) [1,3] r=-1 lpr=0 crt=18'8 lcod 0'0 unknown mbc={}] handle_initialize

/a/sage-2018-12-13_12:24:09-rados-wip-sage2-testing-2018-12-12-1435-distro-basic-smithi/3358111


Related issues

Copied to RADOS - Backport #37821: mimic: ceph-objectstore-tool export from luminous, import to master clears same_interval_since Resolved

History

#1 Updated by Sage Weil 7 months ago

I'm thinking we should make ceph-objectstore-tool refuse to use an export from an older major release (without, say, a --yes-i-really-mean-it type flag). we changed a bunch of stuff with exports/improts between luminous and mimic and mimic and nautilus, and i can't keep it straight.

#2 Updated by Sage Weil 7 months ago

  • Status changed from Verified to Need Review

turns out the upgrade suite already turns import/export tool tests off... let's just do the same.
https://github.com/ceph/ceph/pull/25564

#3 Updated by Neha Ojha 7 months ago

  • Backport set to mimic

#4 Updated by Josh Durgin 7 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #37821: mimic: ceph-objectstore-tool export from luminous, import to master clears same_interval_since added

#6 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF