Project

General

Profile

Bug #36573

mds: ms_handle_authentication does not hold mds lock

Added by Patrick Donnelly about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
Start date:
10/23/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
crash
Pull request ID:

Description

2018-10-19T19:23:17.954 INFO:tasks.ceph.mds.f.smithi161.stderr:/build/ceph-14.0.0-4302-gec20b58/src/mds/MDSContext.cc: In function 'virtual void MDSInternalContextBase::complete(int)' thread 7f9374c66700 time 2018-10-19 19:23:17.954987
2018-10-19T19:23:17.955 INFO:tasks.ceph.mds.f.smithi161.stderr:/build/ceph-14.0.0-4302-gec20b58/src/mds/MDSContext.cc: 29: FAILED ceph_assert(mds->mds_lock.is_locked_by_me())
2018-10-19T19:23:17.960 INFO:tasks.ceph.mds.f.smithi161.stderr: ceph version 14.0.0-4302-gec20b58 (ec20b58b9bf01063bdd2e31a66f67749780e2754) nautilus (dev)
2018-10-19T19:23:17.960 INFO:tasks.ceph.mds.f.smithi161.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x158) [0x7f937a2ed8bf]
2018-10-19T19:23:17.961 INFO:tasks.ceph.mds.f.smithi161.stderr: 2: (ceph::__ceph_assertf_fail(char const*, char const*, int, char const*, char const*, ...)+0) [0x7f937a2eda9c]
2018-10-19T19:23:17.961 INFO:tasks.ceph.mds.f.smithi161.stderr: 3: (MDSInternalContextBase::complete(int)+0x151) [0x787841]
2018-10-19T19:23:17.961 INFO:tasks.ceph.mds.f.smithi161.stderr: 4: (MDSDaemon::ms_handle_authentication(Connection*)+0xbea) [0x4db49a]
2018-10-19T19:23:17.961 INFO:tasks.ceph.mds.f.smithi161.stderr: 5: (Messenger::ms_deliver_verify_authorizer(Connection*, int, int, ceph::buffer::list&, ceph::buffer::list&, bool&, CryptoKey&, std::unique_ptr<AuthAuthorizerChallenge, std::default_delete<AuthAuthorizerChallenge> >*)+0x269) [0x7f937a5902a9]
2018-10-19T19:23:17.961 INFO:tasks.ceph.mds.f.smithi161.stderr: 6: (ProtocolV1::handle_connect_message_2()+0x42a) [0x7f937a5f87aa]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 7: (ProtocolV1::handle_connect_message_auth(char*, int)+0x138) [0x7f937a5fb598]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 8: (()+0x5a855d) [0x7f937a5e155d]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 9: (AsyncConnection::process()+0x186) [0x7f937a5d3d76]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 10: (EventCenter::process_events(unsigned int, std::chrono::duration<unsigned long, std::ratio<1l, 1000000000l> >*)+0x1595) [0x7f937a601235]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 11: (()+0x5d47fa) [0x7f937a60d7fa]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 12: (()+0x862c8f) [0x7f937a89bc8f]
2018-10-19T19:23:17.962 INFO:tasks.ceph.mds.f.smithi161.stderr: 13: (()+0x76ba) [0x7f9379bb26ba]
2018-10-19T19:23:17.963 INFO:tasks.ceph.mds.f.smithi161.stderr: 14: (clone()+0x6d) [0x7f93793db41d]

From: /ceph/teuthology-archive/pdonnell-2018-10-17_19:54:38-multimds-wip-pdonnell-testing-20181017.175152-distro-basic-smithi/3153449/teuthology.log
Caused by: ecbd4a8aa8e6c1c72af4e0be15e0340629bfdc3a and others

History

#1 Updated by Patrick Donnelly about 2 months ago

  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly about 2 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF