Project

General

Profile

Bug #36379

mds: cache drop command only requires read caps

Added by Patrick Donnelly 2 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
High
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
task(easy)
Pull request ID:

Description

https://github.com/ceph/ceph/blob/a6a2f395b7e5f9fd867c0ba83a9e6525485a575d/src/mds/MDSDaemon.cc#L704-L707

This should be "rw" due to its potential impact on performance. Credit to John Spray for catching the issue.


Related issues

Related to fs - Cleanup #36380: mds: remove cap requirement on ceph tell commands Resolved 10/10/2018

History

#1 Updated by Patrick Donnelly 2 months ago

  • Status changed from New to Rejected

Nevermind, turns out MDSDaemon ignores the command caps and checks client has "all":

https://github.com/ceph/ceph/blob/a6a2f395b7e5f9fd867c0ba83a9e6525485a575d/src/mds/MDSDaemon.cc#L613

#2 Updated by Patrick Donnelly 2 months ago

  • Related to Cleanup #36380: mds: remove cap requirement on ceph tell commands added

Also available in: Atom PDF