Project

General

Profile

Bug #36221

mds: rctime not set on system inode (root) at startup

Added by Patrick Donnelly 3 months ago. Updated about 2 months ago.

Status:
Pending Backport
Priority:
High
Category:
-
Target version:
Start date:
09/26/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

pdonnell@senta02 ~/mnt/tmp.gh651ZmDf8$ cd /home/pdonnell/mnt/tmp.P8Kd5vSfhc
pdonnell@senta02 ~/mnt/tmp.P8Kd5vSfhc$ ls -ltac
total 5
drwxr-x--- 21 pdonnell pdonnell 4096 Sep 26 14:12 ..
drwxr-xr-x  2 pdonnell pdonnell    0 Sep 26 14:12 .
pdonnell@senta02 ~/mnt/tmp.P8Kd5vSfhc$ date +%s;find -type d -execdir getfattr -n ceph.dir.rctime {} +
1537985568
# file: .
ceph.dir.rctime="0.090" 

(I haven't yet figured out where this 0.09 comes from; why is it not 0.0?)


Related issues

Copied to fs - Backport #36460: luminous: mds: rctime not set on system inode (root) at startup In Progress
Copied to fs - Backport #36461: mimic: mds: rctime not set on system inode (root) at startup Resolved

History

#1 Updated by Patrick Donnelly 3 months ago

  • Subject changed from mds: rctime/ctime not set on system inode (root) at startup to mds: rctime not set on system inode (root) at startup

#3 Updated by Patrick Donnelly 3 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Patrick Donnelly about 2 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #36460: luminous: mds: rctime not set on system inode (root) at startup added

#6 Updated by Nathan Cutler about 2 months ago

  • Copied to Backport #36461: mimic: mds: rctime not set on system inode (root) at startup added

Also available in: Atom PDF