Project

General

Profile

Bug #36165

qa: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp'

Added by Patrick Donnelly 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
Start date:
09/24/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa
Pull request ID:

Description

2018-09-24T04:05:15.793 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/mmutf8fix.so': Permission denied
2018-09-24T04:05:15.793 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/imtcp.so': Permission denied
2018-09-24T04:05:15.793 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/imjournal.so': Permission denied
2018-09-24T04:05:15.794 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/lmzlibw.so': Permission denied
2018-09-24T04:05:15.794 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/imptcp.so': Permission denied
2018-09-24T04:05:15.794 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/rsyslog/mmjsonparse.so': Permission denied
2018-09-24T04:05:15.794 INFO:tasks.workunit.client.0.smithi189.stderr:rm: cannot remove '/home/ubuntu/cephtest/mnt.0/client.0/tmp/payload.2/multiple_rsync_payload.119459/libmpich.so.12': Permission denied
2018-09-24T04:05:15.849 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 86, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 65, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20180923.160923/qa/tasks/workunit.py", line 136, in task
    cleanup=cleanup)
  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20180923.160923/qa/tasks/workunit.py", line 286, in _spawn_on_all_clients
    timeout=timeout)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 85, in __exit__
    for result in self:
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 99, in next
    resurrect_traceback(result)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 22, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20180923.160923/qa/tasks/workunit.py", line 419, in _run_tests
    args=args,
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 193, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 423, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 155, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 177, in _raise_for_status
    node=self.hostname, label=self.label
CommandFailedError: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp'

From: /ceph/teuthology-archive/pdonnell-2018-09-23_19:17:54-fs-wip-pdonnell-testing-20180923.160923-distro-basic-smithi/3061741/teuthology.log

Caused by:

commit 9e9f3ead363c8bd0d39625295ec6d9a33eb65401 HEAD (upstream/pull/24223/head)
gpg: Signature made Fri 21 Sep 2018 01:01:14 PM PDT
gpg:                using RSA key 88AD60FFD3FC04B6DB87CBAC3A2A7E25BEA8AADB
gpg: Good signature from "Patrick Joseph Donnelly (Hacker) <batrick@batbytes.com>" [ultimate]
gpg:                 aka "Patrick Joseph Donnelly (Software Engineer) <pdonnell@redhat.com>" [ultimate]
Merge: a5c572b13a 1b7cabc732
Author: Patrick Donnelly <pdonnell@redhat.com>
Date:   Fri Sep 21 13:01:14 2018 -0700

    Merge PR #24157 into master

    * refs/pull/24157/head:

Related issues

Related to fs - Bug #24177: qa: fsstress workunit does not execute in parallel on same host without clobbering files Resolved 05/18/2018
Copied to fs - Backport #36322: luminous: qa: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp' Resolved
Copied to fs - Backport #36323: mimic: qa: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp' Resolved

History

#1 Updated by Patrick Donnelly 3 months ago

  • Status changed from In Progress to Need Review

#2 Updated by Patrick Donnelly 3 months ago

  • Related to Bug #24177: qa: fsstress workunit does not execute in parallel on same host without clobbering files added

#3 Updated by Patrick Donnelly 3 months ago

  • Status changed from Need Review to Resolved

#4 Updated by Patrick Donnelly 2 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to mimic,luminous

#5 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #36322: luminous: qa: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp' added

#6 Updated by Nathan Cutler 2 months ago

  • Copied to Backport #36323: mimic: qa: Command failed on smithi189 with status 1: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0 /home/ubuntu/cephtest/mnt.0/client.0/tmp' added

#7 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF