Project

General

Profile

Bug #36069

mgr/dashboard: Support http-only initialization

Added by Boris Ranto 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/backend
Target version:
Start date:
09/14/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The ceph dashboard currently requires a SSL certificate even if it is
not running in the SSL mode since it is always querying for the
certificate file/key pair.

For the mimic back-port, we will also need to add the following patch:

21fbfc9c3a00edfe6063c33c738d49fdba21ea73


Related issues

Copied to mgr - Backport #36123: mimic: mgr/dashboard: Support http-only initialization Resolved

History

#2 Updated by Lenz Grimmer 3 months ago

  • Category set to dashboard/backend
  • Status changed from New to Pending Backport
  • Target version set to v14.0.0
  • Affected Versions v13.2.2, v14.0.0 added

#3 Updated by Nathan Cutler 3 months ago

  • Copied to Backport #36123: mimic: mgr/dashboard: Support http-only initialization added

#4 Updated by Lenz Grimmer 3 months ago

  • Subject changed from [dashboard] Support http-only initialization to mgr/dashboard: Support http-only initialization

#5 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF