Project

General

Profile

Bug #35970

zap not working with LVs

Added by Alfredo Deza 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
09/13/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

# ceph-volume lvm zap --destroy ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6
--> Unmounting /var/lib/ceph/osd/ceph-1
Running command: /bin/umount -v /var/lib/ceph/osd/ceph-1
 stderr: umount:
 stderr: /var/lib/ceph/osd/ceph-1 unmounted
 stderr:
--> Zapping: /dev/ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6
--> Destroying physical volume ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6 because --destroy was given
Running command: /sbin/pvremove -v -f -f ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6
 stderr:
 stderr: Device ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6 not found
 stderr:
--> Unable to remove vg ceph-block-4d0bd451-d033-4a00-9a6f-4b09ddb413ca/osd-block-b502d44e-5194-4c02-bc89-6869a44c90e6
-->  RuntimeError: command returned non-zero exit status: 5

History

Also available in: Atom PDF