Project

General

Profile

Bug #35916

mds: rctime may go back

Added by Zheng Yan 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
09/11/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

code like below can cause rctime to go back

if (new_mtime > pi.inode.ctime)
pi.inode.ctime = pi.inode.rstat.rctime = new_mtime;

The reason is that clients' time is not reliable.


Related issues

Copied to fs - Backport #36135: luminous: mds: rctime may go back Resolved
Copied to fs - Backport #36136: mimic: mds: rctime may go back Resolved

History

#1 Updated by Zheng Yan 3 months ago

  • Status changed from New to Need Review

#2 Updated by Zheng Yan 3 months ago

/ceph/teuthology-archive/pdonnell-2018-09-08_06:58:28-kcephfs-wip-pdonnell-testing-20180908.044939-distro-basic-smithi/2994828/teuthology.log

#3 Updated by Patrick Donnelly 3 months ago

  • Subject changed from rctime may go back to mds: rctime may go back
  • Assignee set to Zheng Yan
  • Priority changed from Normal to High
  • Target version set to v14.0.0
  • Source set to Q/A
  • Backport set to mimic,luminous
  • Component(FS) MDS added

#4 Updated by Patrick Donnelly 3 months ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler 3 months ago

#6 Updated by Nathan Cutler 3 months ago

#7 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF