Project

General

Profile

Bug #35846

ceph-objectstore-tool apply-layout-settings optional target level can't be specified.

Added by David Zafman 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
09/07/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

https://github.com/ceph/ceph/pull/17666 must not have been tested.

$ bin/ceph-objectstore-tool --no-mon-config --data-path dev/osd0/ --pgid 1.0 --op apply-layout-settings 50
Can't specify both --op and object command syntax
...remainder of usage...

Requires the use of awkward syntax "--arg1 50"


Related issues

Related to RADOS - Feature #21366: tools/ceph-objectstore-tool: split filestore directories offline to target hash level Resolved 09/12/2017
Copied to Ceph - Backport #35991: luminous: ceph-objectstore-tool apply-layout-settings optional target level can't be specified. Resolved
Copied to Ceph - Backport #35992: mimic: ceph-objectstore-tool apply-layout-settings optional target level can't be specified. Resolved

History

#1 Updated by David Zafman 3 months ago

  • Related to Feature #21366: tools/ceph-objectstore-tool: split filestore directories offline to target hash level added

#2 Updated by David Zafman 3 months ago

I didn't realize that the --arg1 syntax can be used to specify the value for a positional argument. The positional arguments are "object" "objcmd" "arg1" "arg2" in that order which are intended to be used for object related commands with the exception of special --op list and --op apply-layout-feature

sudo ceph-objectstore-tool --data-path /data/lib/ceph/osd/ceph-0/ --op apply-layout-settings --pool "cephfs_data" --arg1 5

I still want to fix this. Allowing the first positional argument or the "arg1" argument to work. It will also work to do the following:

sudo ceph-objectstore-tool --data-path /data/lib/ceph/osd/ceph-0/ --op apply-layout-settings --pool "cephfs_data" 5

#3 Updated by David Zafman 3 months ago

  • Backport set to mimic, luminous

#4 Updated by David Zafman 3 months ago

  • Status changed from New to In Progress

#5 Updated by David Zafman 3 months ago

  • Copied to Backport #35991: luminous: ceph-objectstore-tool apply-layout-settings optional target level can't be specified. added

#6 Updated by David Zafman 3 months ago

  • Copied to Backport #35992: mimic: ceph-objectstore-tool apply-layout-settings optional target level can't be specified. added

#7 Updated by David Zafman 3 months ago

  • Status changed from In Progress to Pending Backport

#8 Updated by David Zafman 3 months ago

  • Description updated (diff)

#10 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF