Project

General

Profile

Bug #35845

osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed

Added by Neha Ojha 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
09/07/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

2018-09-06T17:29:18.115 INFO:tasks.workunit.client.0.smithi155.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3003: TEST_corrupt_scrub_replicated:  '[' 2 '!=' 0 ']'
2018-09-06T17:29:18.116 INFO:tasks.workunit.client.0.smithi155.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3005: TEST_corrupt_scrub_replicated:  echo 'TEST FAILED WITH 2 ERRORS'
2018-09-06T17:29:18.116 INFO:tasks.workunit.client.0.smithi155.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3006: TEST_corrupt_scrub_replicated:  return 1
2018-09-06T17:29:18.116 INFO:tasks.workunit.client.0.smithi155.stdout:TEST FAILED WITH 2 ERRORS

/a/yuriw-2018-09-06_15:14:44-rados-wip-yuriw--9.5.18_mimic-distro-basic-smithi/2985283/


Related issues

Copied to RADOS - Backport #35909: mimic: osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed Resolved
Copied to RADOS - Backport #36393: luminous: osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed Resolved

History

#1 Updated by David Zafman 3 months ago

This must be caused by differences in the grep command on different distributions. It passes sometimes including on my build machine Ubuntu 16.04.

The 2 errors are missing log entries. However, looking at the logs shows that they are present. Notice that brackets "[" and in some case parens "(" ")" are escaped. I think the first one is broken because parens aren't always escaped, But I'm not sure why the second one also fails.

Missing log message 'log_channel[(]cluster[)] log [[]ERR[]] : scrub [0-9]*[.]0 3:5c7b2c47:::ROBJ16:head : can't decode 'snapset' attr buffer::malformed_input: void SnapSet::decode(ceph::buffer::list::const_iterator&) no longer understand old encoding version 3 < 97'
Missing log message 'log_channel[(]cluster[)] log [[]ERR[]] : deep-scrub [0-9]*[.]0 3:5c7b2c47:::ROBJ16:head : can't decode 'snapset' attr buffer::malformed_input: void SnapSet::decode[(]ceph::buffer::list::const_iterator&[)] no longer understand old encoding version 3 < 97'

#2 Updated by David Zafman 3 months ago

  • Subject changed from mimic:osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed to osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed
  • Status changed from New to In Progress
  • Source set to Development
  • Backport set to mimic, luminous

#4 Updated by David Zafman 3 months ago

It turns out this is just a difference in the iterator for the function throwing the exception.

log_channel(cluster) log [ERR] : scrub 3.0 3:5c7b2c47:::ROBJ16:head : can't decode 'snapset' attr buffer::malformed_input: void SnapSet::decode(ceph::buffer::list::const_iterator&) no longer understand old encoding version 3 < 97
vs
log_channel(cluster) log [ERR] : scrub 3.0 3:5c7b2c47:::ROBJ16:head : can't decode 'snapset' attr buffer::malformed_input: void SnapSet::decode(ceph::buffer::list::iterator&) no longer understand old encoding version 3 < 97

#5 Updated by Nathan Cutler 3 months ago

  • Backport changed from mimic, luminous to mimic, luminous, jewel

Adding jewel because we are seeing an "osd-scrub-repair.sh" make check issue in jewel (not sure if it's this same issue, but it seems wise to backport any fixes to jewel as well, as long as downstreams are using it).

#7 Updated by David Zafman 3 months ago

  • Copied to Backport #35909: mimic: osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed added

#8 Updated by David Zafman 3 months ago

  • Backport changed from mimic, luminous, jewel to mimic

The test code that needs to be fixed is only present in Mimic and master.

#9 Updated by Neha Ojha 2 months ago

2018-10-05T10:58:17.914 INFO:tasks.workunit.client.0.smithi029.stdout:TEST FAILED WITH 4 ERRORS
2018-10-05T10:58:17.914 INFO:tasks.workunit.client.0.smithi029.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3009: TEST_corrupt_scrub_replicated:  '[' 4 '!=' 0 ']'
2018-10-05T10:58:17.914 INFO:tasks.workunit.client.0.smithi029.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3011: TEST_corrupt_scrub_replicated:  echo 'TEST FAILED WITH 4 ERRORS'
2018-10-05T10:58:17.914 INFO:tasks.workunit.client.0.smithi029.stderr:/home/ubuntu/cephtest/clone.client.0/qa/standalone/scrub/osd-scrub-repair.sh:3012: TEST_corrupt_scrub_replicated:  return 1

/a/yuriw-2018-10-04_23:07:41-rados-wip-yuri-testing-2018-10-04-2118-luminous-distro-basic-smithi/3102041/

David, this seems to be present in luminous as well.

#10 Updated by Neha Ojha 2 months ago

  • Backport changed from mimic to luminous,mimic

#11 Updated by David Zafman 2 months ago

  • Copied to Backport #36393: luminous: osd-scrub-repair.sh:TEST_corrupt_scrub_replicated failed added

#12 Updated by Nathan Cutler 2 months ago

  • Status changed from In Progress to Pending Backport

#13 Updated by Nathan Cutler about 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF