Project

General

Profile

Bug #35829

qa: workunits/fs/misc/acl.sh failure from unexpected system.posix_acl_default attribute

Added by Patrick Donnelly 3 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
09/06/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
kceph, qa-suite
Labels (FS):
qa
Pull request ID:

Description

2018-09-05T14:28:09.116 INFO:tasks.workunit.client.1.smithi192.stderr:+ mkdir d1
2018-09-05T14:28:09.122 INFO:tasks.workunit.client.0.smithi192.stderr:+ setfattr -n system.posix_acl_access -v 0x02000000 d1
2018-09-05T14:28:09.122 INFO:tasks.workunit.client.1.smithi192.stderr:+ setfattr -n system.posix_acl_access -v 0x02000000 d1
2018-09-05T14:28:09.154 INFO:tasks.workunit.client.1.smithi192.stderr:+ setfattr -n system.posix_acl_default -v 0x02000000 .
2018-09-05T14:28:09.154 INFO:tasks.workunit.client.0.smithi192.stderr:+ setfattr -n system.posix_acl_default -v 0x02000000 .
2018-09-05T14:28:09.158 INFO:tasks.workunit.client.1.smithi192.stderr:+ expect_failure getfattr -n system.posix_acl_access d1
2018-09-05T14:28:09.159 INFO:tasks.workunit.client.1.smithi192.stderr:+ getfattr -n system.posix_acl_access d1
2018-09-05T14:28:09.161 INFO:tasks.workunit.client.0.smithi192.stderr:+ expect_failure getfattr -n system.posix_acl_access d1
2018-09-05T14:28:09.161 INFO:tasks.workunit.client.0.smithi192.stderr:+ getfattr -n system.posix_acl_access d1
2018-09-05T14:28:09.187 INFO:tasks.workunit.client.0.smithi192.stderr:d1: system.posix_acl_access: No such attribute
2018-09-05T14:28:09.187 INFO:tasks.workunit.client.1.smithi192.stderr:d1: system.posix_acl_access: No such attribute
2018-09-05T14:28:09.188 INFO:tasks.workunit.client.0.smithi192.stderr:+ return 0
2018-09-05T14:28:09.188 INFO:tasks.workunit.client.0.smithi192.stderr:+ expect_failure getfattr -n system.posix_acl_default .
2018-09-05T14:28:09.188 INFO:tasks.workunit.client.0.smithi192.stderr:+ getfattr -n system.posix_acl_default .
2018-09-05T14:28:09.188 INFO:tasks.workunit.client.1.smithi192.stderr:+ return 0
2018-09-05T14:28:09.189 INFO:tasks.workunit.client.1.smithi192.stderr:+ expect_failure getfattr -n system.posix_acl_default .
2018-09-05T14:28:09.189 INFO:tasks.workunit.client.1.smithi192.stderr:+ getfattr -n system.posix_acl_default .
2018-09-05T14:28:09.190 INFO:tasks.workunit.client.1.smithi192.stderr:.: system.posix_acl_default: No such attribute
2018-09-05T14:28:09.190 INFO:tasks.workunit.client.1.smithi192.stderr:+ return 0
2018-09-05T14:28:09.190 INFO:tasks.workunit.client.1.smithi192.stderr:+ rmdir d1
2018-09-05T14:28:09.195 INFO:tasks.workunit.client.1.smithi192.stderr:+ cd ..
2018-09-05T14:28:09.196 INFO:tasks.workunit.client.1.smithi192.stderr:+ rmdir testdir
2018-09-05T14:28:09.221 INFO:tasks.workunit.client.1.smithi192.stderr:+ echo OK
2018-09-05T14:28:09.221 INFO:tasks.workunit.client.1.smithi192.stdout:OK
2018-09-05T14:28:09.222 INFO:teuthology.orchestra.run.smithi192:Running: 'sudo rm -rf -- /home/ubuntu/cephtest/mnt.1/client.1/tmp'
2018-09-05T14:28:09.222 INFO:tasks.workunit.client.0.smithi192.stdout:# file: .
2018-09-05T14:28:09.222 INFO:tasks.workunit.client.0.smithi192.stdout:system.posix_acl_default=0sAgAAAAEABwD/////AgAGAP7/AAAEAAcA/////xAABwD/////IAAFAP////8=
2018-09-05T14:28:09.222 INFO:tasks.workunit.client.0.smithi192.stdout:
2018-09-05T14:28:09.223 INFO:tasks.workunit.client.0.smithi192.stderr:+ return 1
2018-09-05T14:28:09.223 INFO:tasks.workunit:Stopping ['fs/misc'] on client.0...
2018-09-05T14:28:09.224 INFO:teuthology.orchestra.run.smithi192:Running: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0'
...
2018-09-05T14:28:13.592 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 86, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 65, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/github.com_batrick_ceph_kcephfs-distro-kernel/qa/tasks/workunit.py", line 206, in task
    cleanup=cleanup)
  File "/home/teuthworker/src/github.com_batrick_ceph_kcephfs-distro-kernel/qa/tasks/workunit.py", line 356, in _spawn_on_all_clients
    timeout=timeout)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 85, in __exit__
    for result in self:
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 99, in next
    resurrect_traceback(result)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 22, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/github.com_batrick_ceph_kcephfs-distro-kernel/qa/tasks/workunit.py", line 479, in _run_tests
    label="workunit test {workunit}".format(workunit=workunit)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/remote.py", line 193, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 423, in run
    r.wait()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 155, in wait
    self._raise_for_status()
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/orchestra/run.py", line 177, in _raise_for_status
    node=self.hostname, label=self.label
CommandFailedError: Command failed (workunit test fs/misc/acl.sh) on smithi192 with status 1: 'mkdir -p -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && cd -- /home/ubuntu/cephtest/mnt.0/client.0/tmp && CEPH_CLI_TEST_DUP_COMMAND=1 CEPH_REF=kcephfs-distro-kernel TESTDIR="/home/ubuntu/cephtest" CEPH_ARGS="--cluster ceph" CEPH_ID="0" PATH=$PATH:/usr/sbin CEPH_BASE=/home/ubuntu/cephtest/clone.client.0 CEPH_ROOT=/home/ubuntu/cephtest/clone.client.0 adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 6h /home/ubuntu/cephtest/clone.client.0/qa/workunits/fs/misc/acl.sh'

From: /ceph/teuthology-archive/pdonnell-2018-09-04_22:08:29-multimds-wip-pdonnell-testing-20180904.143045-distro-basic-smithi/2980663/teuthology.log


Related issues

Related to fs - Bug #24177: qa: fsstress workunit does not execute in parallel on same host without clobbering files Resolved 05/18/2018

History

#1 Updated by Zheng Yan 3 months ago

looks like the test executes qa/workunits/fs/misc/acl.sh on two mounts at the same time. acl.sh is not designed be run parallelly

#2 Updated by Patrick Donnelly 3 months ago

  • Related to Bug #24177: qa: fsstress workunit does not execute in parallel on same host without clobbering files added

#3 Updated by Zheng Yan 2 months ago

  • Status changed from New to Rejected

test case issue

Also available in: Atom PDF