Project

General

Profile

Bug #34320

mgr/dashboard: Read/Write OPS in pool stats always show 0

Added by Volker Theile 4 months ago. Updated about 1 month ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Category:
dashboard/backend
Target version:
Start date:
08/29/2018
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

In the dashboard 'Pools' widget the Read/Write ops are always 0. I assume the CephService::get_pool_list_with_stats method is doing something wrong.

aaa6445724a2edbcf7378185dbc7ce17.png View (77.2 KB) Volker Theile, 08/29/2018 03:51 PM


Related issues

Related to mgr - Bug #36740: mgr/dashboard: PG Stats, Pool usage and read/write ops missing from Pools table Need Review 11/09/2018
Related to mgr - Feature #36675: mgr/dashboard: Provide API endpoint providing minimal health data Resolved 11/01/2018

History

#1 Updated by Lenz Grimmer 4 months ago

  • Category changed from dashboard/backend to python interface
  • Assignee set to John Spray

@John, maybe something for you to take a look at?

#2 Updated by John Spray 4 months ago

  • Assignee deleted (John Spray)

The get_pool_list_with_stats implementation looks strange to me.

It seems to be trying to construct some deque time series in pool_stats, but pool_stats is a local that's construct each time the function is called. The later call to get_rate is probably always returning 0 because the length of the series is only ever 1.

Look at how update_pool_stats is used in the luminous dashboard -- it's called each time we get a pg_summary notification, and maintains the time series as an attribute of the MgrModule instance, so that it's always there when something else wants to read it.

#3 Updated by Volker Theile 4 months ago

  • Assignee set to Ricardo Dias

#4 Updated by Lenz Grimmer 3 months ago

Just to elaborate on this a bit (thank you John for the clarification on IRC): this needs to be fixed in the Ceph Manager dashboard module backend:

The underlying ceph-mgr bits just give the current statistics (via the pgmap summary) -- the calculation of the rate would happen in the dashboard

#5 Updated by Lenz Grimmer 3 months ago

  • Category changed from python interface to dashboard/backend

#6 Updated by Lenz Grimmer about 1 month ago

  • Related to Bug #36740: mgr/dashboard: PG Stats, Pool usage and read/write ops missing from Pools table added

#7 Updated by Lenz Grimmer about 1 month ago

  • Status changed from New to Won't Fix

Resolving as "Won't fix", as the pools table has been removed when the new landing page was introduced with #35691.
We should revisit this when #36740 will be addressed.

#8 Updated by Lenz Grimmer about 1 month ago

  • Related to Feature #36675: mgr/dashboard: Provide API endpoint providing minimal health data added

Also available in: Atom PDF