Project

General

Profile

Bug #2841

rgw: fix usage trim

Added by Yehuda Sadeh over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
Start date:
07/25/2012
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
argonaut
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

looking at the code, it seems that we don't encode the user in usage-trim (and also encode the wrong structure).

Associated revisions

Revision 6bc1067f (diff)
Added by Yehuda Sadeh over 6 years ago

rgw: fix usage trim call encoding

Fixes: #2841.
Usage trim operation was encoding the wrong op structure (usage read).
Since the structures somewhat overlapped it somewhat worked, but user
info wasn't encoded.

Backport: argonaut
Signed-off-by: Yehuda Sadeh <>

Revision d4849f2f (diff)
Added by Yehuda Sadeh over 6 years ago

rgw: fix usage trim call encoding

Fixes: #2841.
Usage trim operation was encoding the wrong op structure (usage read).
Since the structures somewhat overlapped it somewhat worked, but user
info wasn't encoded.

Backport: argonaut
Signed-off-by: Yehuda Sadeh <>

History

#1 Updated by Anonymous over 6 years ago

  • Target version set to Ceph - v0.51

#2 Updated by Yehuda Sadeh over 6 years ago

  • Status changed from New to Need Review

#3 Updated by Yehuda Sadeh over 6 years ago

  • Backport set to argonaut

#4 Updated by Yehuda Sadeh over 6 years ago

  • Status changed from Need Review to Resolved

Fixed, commit:6bc1067fc878cbfb6761146cb154c2985c9d9bd7 and commit:04a0eacd92b0c923cb9d1efc7d751a05d544dc85

Also available in: Atom PDF