Project

General

Profile

Bug #26883

ceph-mgr package does not remove /usr/lib/ceph/mgr compiled files (Debian only?)

Added by Dan Mick 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Build
Target version:
-
Start date:
08/08/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

it appears as though debian/rules is using dh_python2 fairly straightforwardly, but neither a pycompile nor a pyclean is in any of the various scripts; not sure why yet, but it leaves detritus on the system after the package is removed.


Related issues

Copied to mgr - Backport #27058: luminous: ceph-mgr package does not remove /usr/lib/ceph/mgr compiled files (Debian only?) Resolved
Copied to mgr - Backport #27059: mimic: ceph-mgr package does not remove /usr/lib/ceph/mgr compiled files (Debian only?) Resolved

History

#1 Updated by Greg Farnum 4 months ago

  • Project changed from Ceph to mgr
  • Category changed from build to Build

Do packages for debian even work? Is this actually happening on an Ubuntu machine?

#2 Updated by Dan Mick 4 months ago

I meant the generic Debian. Yes Ubuntu

#3 Updated by Dan Mick 4 months ago

  • Status changed from New to Need Review
  • Assignee set to Dan Mick

another invocation of dh_python2 for a "private directory" seems to be the dh answer.

#5 Updated by Kefu Chai 4 months ago

  • Status changed from Need Review to Pending Backport
  • Backport set to luminous,mimic

#6 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #27058: luminous: ceph-mgr package does not remove /usr/lib/ceph/mgr compiled files (Debian only?) added

#7 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #27059: mimic: ceph-mgr package does not remove /usr/lib/ceph/mgr compiled files (Debian only?) added

#8 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF