Project

General

Profile

Bug #24925

qa: pjd test failed ctime change unexpected result

Added by Patrick Donnelly 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
07/15/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client, MDS, qa-suite
Labels (FS):
qa
Pull request ID:

Description

2018-07-15T05:24:32.032 INFO:tasks.workunit.client.0.smithi099.stderr:+ ntest=102
2018-07-15T05:24:32.033 INFO:tasks.workunit.client.0.smithi099.stderr:++ /home/ubuntu/cephtest/mnt.0/client.0/tmp/tmp/../pjd-fstest-20090130-RC/tests/chown/../../fstest stat fstest_956b8cca3c3abaafea70c6dd88c26ce1 ctime
2018-07-15T05:24:32.042 INFO:tasks.workunit.client.0.smithi099.stderr:+ ctime2=1531632271
2018-07-15T05:24:32.042 INFO:tasks.workunit.client.0.smithi099.stderr:+ test_check 1531632271 -lt 1531632271
2018-07-15T05:24:32.042 INFO:tasks.workunit.client.0.smithi099.stderr:+ '[' 1531632271 -lt 1531632271 ']'
2018-07-15T05:24:32.043 INFO:tasks.workunit.client.0.smithi099.stderr:+ echo 'not ok 102'
2018-07-15T05:24:32.044 INFO:tasks.workunit.client.0.smithi099.stderr:++ expr 102 + 1

/ceph/teuthology-archive/pdonnell-2018-07-14_03:28:54-multimds-wip-pdonnell-testing-20180714.012714-testing-basic-smithi/2780610/teuthology.log

History

#1 Updated by Patrick Donnelly 5 months ago

  • Assignee set to Zheng Yan

#2 Updated by Zheng Yan 5 months ago

  • Status changed from New to Rejected
2018-07-15 05:24:31.060 7f04c1582700 10 client.4428 fill_stat on 0x1000000011b snap/devhead mode 040755 mtime 2018-07-15 05:24:31.063143 ctime 2018-07-15 05:24:31.063143
2018-07-15 05:24:31.060 7f04c1582700 15 inode.get on 0x559a4f422680 0x1000000011b.head now 4
2018-07-15 05:24:31.060 7f04c1582700 20 client.4428 _ll_get 0x559a4f422680 0x1000000011b -> 1
2018-07-15 05:24:31.060 7f04c1582700  3 client.4428 ll_mkdir 0x1000000010d.head fstest_956b8cca3c3abaafea70c6dd88c26ce1 = 0 (1000000011b)
2018-07-15 05:24:31.060 7f04c1582700 10 client.4428 put_inode on 0x1000000011b.head(faked_ino=0 ref=4 ll_ref=1 cap_refs={} open={} mode=40755 size=0/0 nlink=1 btime=2018-07-15 05:24:31.063143 mtime=2018-07-15 05:24:31.063143 ctime=2018-07-15 05:24:31.063143 caps=pAsxLsXsxFsx(0=pAsxLsXsxFsx) COMPLETE parents=0x1000000010d.head["fstest_956b8cca3c3abaafea70c6dd88c26ce1"] 0x559a4f422680)

...

2018-07-15 05:24:31.995 7f04c0580700 10 client.4428 _do_setattr mask 6 issued pAsxLsXsxFsx
2018-07-15 05:24:31.995 7f04c0580700 10 mark_caps_dirty 0x1000000011b.head(faked_ino=0 ref=4 ll_ref=4 cap_refs={} open={} mode=40755 size=0/0 nlink=1 btime=2018-07-15 05:24:31.063143 mtime=2018-07-15 05:24:31.063143 ctime=2018-07-15 05:24:31.998738 caps=pAsxLsXsxFsx(0=pAsxLsXsxFsx) COMPLETE parents=0x1000000010d.head["fstest_956b8cca3c3abaafea70c6dd88c26ce1"] 0x559a4f422680) - -> Ax

caused by short sleep

Also available in: Atom PDF