Project

General

Profile

Bug #24896

rgw fail to put elasticsearch document when compression is set

Added by hikdata hik 4 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/13/2018
Due date:
% Done:

0%

Source:
Tags:
rgw
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
rgw
Pull request ID:

Description

we build a radosgw multisite with one zonegroup, it contains one normal zone and one elasticsearch zone. then we create a placement policy with compression is zlib. Then we create a bucket with this placement and create objects. However, the index documents are not created for these objects. the rgw log shows, it create index document from object metadata, but documents are rejected by elasticsearch server. The elasticsearch server returns 400 error.

History

#1 Updated by Greg Farnum 4 months ago

  • Project changed from RADOS to rgw

#2 Updated by Abhishek Lekshmanan 4 months ago

  • Status changed from New to Pending Backport

Probably fixed in https://github.com/ceph/ceph/pull/20796 whihc can be backported to luminous

#3 Updated by Patrick Donnelly 3 months ago

backport field is empty

#4 Updated by Nathan Cutler 3 months ago

  • Backport set to mimic,luminous

#7 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Duplicate
  • Target version deleted (v12.2.8)
  • Backport deleted (mimic,luminous)

The fix for this bug, https://github.com/ceph/ceph/pull/20796, was included in v13.2.0 (so mimic backport was not needed). Also, this is the same fix as the one for #22758 which has already been backported to luminous. Removing backport issues and marking this a duplicate of #22758.

Also available in: Atom PDF