Project

General

Profile

Bug #24794

ceph-volume detects missing options too late

Added by S├ębastien Han 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
07/06/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Trying to prepare a filestore encrypted OSD:

[root@ceph-osd0 /]# ceph-volume lvm prepare --data /dev/sda --dmcrypt --filestore
Running command: /bin/ceph-authtool --gen-print-key
Running command: /bin/ceph-authtool --gen-print-key
Running command: /bin/ceph --cluster ceph --name client.bootstrap-osd --keyring /var/lib/ceph/bootstrap-osd/ceph.keyring -i - osd new 50b376b3-9b2f-4e2d-b478-d86c1bec4bcb
--> Was unable to complete a new OSD, will rollback changes
--> OSD will be fully purged from the cluster, because the ID was generated
Running command: /bin/ceph osd purge osd.2 --yes-i-really-mean-it
 stderr: purged osd.2
-->  RuntimeError: --journal is required when using --filestore

It seems that ceph-volume is waiting a bit too much to tell that the --journal is missing.

History

#1 Updated by Alfredo Deza 3 months ago

  • Status changed from New to In Progress

#2 Updated by Alfredo Deza 3 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF