Project

General

Profile

Bug #24687

Automatically set expected_num_objects for new pools with >=100 PGs per OSD

Added by Douglas Fuller 6 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
Administration/Usability
Target version:
-
Start date:
06/28/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Monitor, OSD
Pull request ID:

Description

Field experience has demonstrated significant performance impact from filestore split and merge activity. The expected_num_objects hint to ceph osd pool create mitigates this impact. Assume that pools created with 50 or more PGs per OSD are expected to store a large number of objects and pre-split their collections automatically.


Related issues

Blocked by RADOS - Bug #24686: change default filestore_merge_threshold to -10 Resolved 06/28/2018
Blocks RADOS - Cleanup #25124: Add message to consult pgcalc for expected_num_objects New 07/26/2018
Copied to RADOS - Backport #25144: mimic: Automatically set expected_num_objects for new pools with >=100 PGs per OSD Resolved
Copied to RADOS - Backport #25145: luminous: Automatically set expected_num_objects for new pools with >=100 PGs per OSD Resolved

History

#1 Updated by Douglas Fuller 6 months ago

  • Blocked by Bug #24686: change default filestore_merge_threshold to -10 added

#2 Updated by Douglas Fuller 6 months ago

  • Subject changed from Automatically set expected_num_objects for new pools with >50 PGs per OSD to Automatically set expected_num_objects for new pools with >=50 PGs per OSD

#3 Updated by Douglas Fuller 6 months ago

Also include >1024 PGs overall

#4 Updated by Nathan Cutler 5 months ago

  • Backport changed from luminous to mimic,luminous

#5 Updated by Douglas Fuller 5 months ago

  • Status changed from In Progress to Need Review

Because a value for expected_num_objects is too difficult to determine automatically, instead we print a suggestion that the user consult pgcalc.

#7 Updated by Neha Ojha 5 months ago

  • Subject changed from Automatically set expected_num_objects for new pools with >=50 PGs per OSD to Automatically set expected_num_objects for new pools with >=100 PGs per OSD
  • Status changed from Need Review to Testing

#8 Updated by Douglas Fuller 5 months ago

Removed pgcalc message while pgcalc updates are considered

#9 Updated by Douglas Fuller 5 months ago

  • Blocks Cleanup #25124: Add message to consult pgcalc for expected_num_objects added

#10 Updated by Douglas Fuller 5 months ago

  • Status changed from Testing to Pending Backport

#11 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #25144: mimic: Automatically set expected_num_objects for new pools with >=100 PGs per OSD added

#12 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #25145: luminous: Automatically set expected_num_objects for new pools with >=100 PGs per OSD added

#13 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF