Project

General

Profile

Bug #24640

test_cls_rgw.sh cls_rgw.index_suggest fail with EINVAL

Added by Sage Weil 11 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
06/23/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2018-06-22T19:21:47.155 INFO:tasks.workunit.client.0.smithi175.stdout:[ RUN      ] cls_rgw.index_suggest
2018-06-22T19:21:48.841 INFO:tasks.workunit.client.0.smithi175.stdout:/home/jenkins-build/build/workspace/ceph-dev-new-build/ARCH/x86_64/AVAILABLE_ARCH/x86_64/AVAILABLE_DIST/centos7/DIST/centos7/MACHINE_SIZE/huge/release/14.0.0-768-g27371cf/rpm/el7/BUILD/ceph-14.0.0-768-g27371cf/src/test/cls_rgw/test_cls_rgw.cc:373
: Failure
2018-06-22T19:21:48.841 INFO:tasks.workunit.client.0.smithi175.stdout:      Expected: 0
2018-06-22T19:21:48.842 INFO:tasks.workunit.client.0.smithi175.stdout:To be equal to: ioctx.operate(bucket_oid, op)
2018-06-22T19:21:48.842 INFO:tasks.workunit.client.0.smithi175.stdout:      Which is: -22
2018-06-22T19:21:48.842 INFO:tasks.workunit.client.0.smithi175.stdout:[  FAILED  ] cls_rgw.index_suggest (1686 ms)

/a/sage-2018-06-22_17:54:15-rados-wip-sage-testing-20180622-0924-distro-basic-smithi/2690110

Related issues

Related to RADOS - Bug #24787: cls_rgw.index_suggest FAILED Duplicate 07/05/2018
Related to rgw - Bug #24280: rgw: fail to recover index from crash Resolved 05/24/2018
Duplicated by rgw - Bug #25071: Workunit test cls/test_cls_rgw.sh fails in upgrade/luminous-x/parallel (master) Duplicate 07/24/2018

History

#1 Updated by Casey Bodley 11 months ago

likely caused by recent changes to rgw_dir_suggest_changes() in https://github.com/ceph/ceph/pull/22217

#2 Updated by Casey Bodley 11 months ago

  • Assignee set to Eric Ivancich

#3 Updated by Eric Ivancich 11 months ago

I have confirmed that commit https://github.com/ceph/ceph/pull/22217 is the culprit. The commit before the merge succeeds on the test, the commit with the merge fails.

Will now work on diagnosing underlying issue.

#5 Updated by Eric Ivancich 11 months ago

I'm currently evaluating the fix.

#6 Updated by Yuri Weinstein 11 months ago

  • Related to Bug #24787: cls_rgw.index_suggest FAILED added

#7 Updated by Sage Weil 11 months ago

  • Related to Bug #24280: rgw: fail to recover index from crash added

#9 Updated by Eric Ivancich 10 months ago

Tianshan Qu wrote:

fix in https://github.com/ceph/ceph/pull/22798

This PR was closed and replaced with PR in previous comment.

#10 Updated by Nathan Cutler 10 months ago

  • Duplicated by Bug #25071: Workunit test cls/test_cls_rgw.sh fails in upgrade/luminous-x/parallel (master) added

#11 Updated by Nathan Cutler 10 months ago

  • Backport set to mimic, luminous

#12 Updated by Nathan Cutler 10 months ago

I added "Backport: mimic, luminous" because the mimic and luminous versions of ceph_test_cls_rgw are now broken when run against a cluster running master/nautilus.

#13 Updated by Eric Ivancich 10 months ago

Nathan Cutler wrote:

I added "Backport: mimic, luminous" because the mimic and luminous versions of ceph_test_cls_rgw are now broken when run against a cluster running master/nautilus.

Yes, the backports are appropriate. Their trackers are -- http://tracker.ceph.com/issues/24629 and http://tracker.ceph.com/issues/24628.

#14 Updated by Nathan Cutler 10 months ago

  • Backport deleted (mimic, luminous)

Eric is backporting #24280 and #24640 together - the backport PRs are already open and they contain both fixes, so dropping the backport tag for this one.

#15 Updated by Yuri Weinstein 10 months ago

Eric Ivancich wrote:

Addressed by https://github.com/ceph/ceph/pull/22937 .

merged

#16 Updated by Orit Wasserman 9 months ago

  • Status changed from Verified to Resolved

Also available in: Atom PDF