Project

General

Profile

Bug #24518

"pjd.sh: line 7: cd: too many arguments" in fs suite

Added by Yuri Weinstein 6 months ago. Updated 6 months ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
06/13/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
4 - irritation
Reviewed:
Affected Versions:
ceph-qa-suite:
fs, powercycle
Component(FS):
qa-suite
Labels (FS):
qa
Pull request ID:

Description

This seems to be bionic specific
Run: http://pulpito.ceph.com/yuriw-2018-06-12_21:09:43-fs-master-distro-basic-smithi/
Jobs: '2659765', '2659794', '2659820'
Logs: http://qa-proxy.ceph.com/teuthology/yuriw-2018-06-12_21:09:43-fs-master-distro-basic-smithi/2659765/teuthology.log

2018-06-13T02:37:11.461 INFO:tasks.workunit.client.0.smithi166.stdout:pjd-fstest-20090130-RC/Makefile
2018-06-13T02:37:11.463 INFO:tasks.workunit.client.0.smithi166.stdout:pjd-fstest-20090130-RC/fstest.c
2018-06-13T02:37:11.467 INFO:tasks.workunit.client.0.smithi166.stdout:pjd-fstest-20090130-RC/LICENSE
2018-06-13T02:37:11.480 INFO:tasks.workunit.client.0.smithi166.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/suites/pjd.sh: line 7: cd: too many arguments
2018-06-13T02:37:11.481 INFO:tasks.workunit:Stopping ['suites/pjd.sh'] on client.0...
2018-06-13T02:37:11.481 INFO:teuthology.orchestra.run.smithi166:Running: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0'
2018-06-13T02:37:11.645 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 86, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/run_tasks.py", line 65, in run_one_task
    return task(**kwargs)
  File "/home/teuthworker/src/github.com_ceph_ceph_wip-wusui-24138/qa/tasks/workunit.py", line 206, in task
    cleanup=cleanup)
  File "/home/teuthworker/src/github.com_ceph_ceph_wip-wusui-24138/qa/tasks/workunit.py", line 356, in _spawn_on_all_clients
    timeout=timeout)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 85, in __exit__
    for result in self:
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 99, in next
    resurrect_traceback(result)
  File "/home/teuthworker/src/git.ceph.com_git_teuthology_master/teuthology/parallel.py", line 22, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/github.com_ceph_ceph_wip-wusui-24138/qa/tasks/workunit.py", line 479, in _run_tests

History

#1 Updated by Yuri Weinstein 6 months ago

Also seems like in run:
http://pulpito.ceph.com/yuriw-2018-06-12_21:34:02-powercycle-mimic-distro-basic-smithi/
Jobs: '2660110', '2660054', '2659942', '2659998'

#2 Updated by Yuri Weinstein 6 months ago

  • ceph-qa-suite powercycle added

#3 Updated by Greg Farnum 6 months ago

  • Project changed from Ceph to fs

#4 Updated by Patrick Donnelly 6 months ago

  • Priority changed from Normal to High
  • Target version set to v14.0.0
  • Backport set to mimic,luminous
  • Severity changed from 3 - minor to 4 - irritation
  • Affected Versions deleted (v13.0.0)
  • Component(FS) qa-suite added
  • Labels (FS) qa added

Line in question: https://github.com/ceph/ceph/blob/2d2293948066cae8d656dfe91bdb6695958a52e9/qa/workunits/suites/pjd.sh#L7

I don't see how that could possibly be anything other than 1 argument. Perhaps Ubuntu is using a different shell instead of bash with funky shell expansion? I tested on Arch which has the latest bash and couldn't reproduce the error with the same sequence of commands.

#5 Updated by Patrick Donnelly 6 months ago

  • Status changed from New to Duplicate

Yuri, you're using an old qa-suite branch. Thanks to Neha for noticing the cause.

#6 Updated by Patrick Donnelly 6 months ago

  • Duplicated by Bug #24522: blogbench.sh failed in upgrade:luminous-x-mimic-distro-basic-smithi added

#7 Updated by Patrick Donnelly 6 months ago

  • Duplicated by deleted (Bug #24522: blogbench.sh failed in upgrade:luminous-x-mimic-distro-basic-smithi)

Also available in: Atom PDF