Project

General

Profile

Bug #24467

mds: low wrlock efficiency due to dirfrags traversal

Added by Xuehan Xu 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Performance/Resource Usage
Target version:
Start date:
06/09/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
multimds
Pull request ID:

Description

Recently, when trying to create/remove massive files/dirs(7x10^6) within a common directory, we found that as the creations go on, the time to create a single file/dir increases. After a series analysis, we found that this is due to the traversal of dirfrags the number of which increases exponentially as the number of subdirs/subfiles increases.


Related issues

Copied to fs - Backport #24696: luminous: mds: low wrlock efficiency due to dirfrags traversal Resolved
Copied to fs - Backport #24704: mimic: mds: low wrlock efficiency due to dirfrags traversal Resolved

History

#1 Updated by Kefu Chai 6 months ago

  • Category set to Performance/Resource Usage
  • Status changed from New to Need Review
  • Assignee set to Xuehan Xu

#2 Updated by Patrick Donnelly 6 months ago

  • Subject changed from low wrlock efficiency due to dirfrags traversal to mds: low wrlock efficiency due to dirfrags traversal
  • Status changed from Need Review to Pending Backport
  • Source set to Development
  • Backport set to luminous,mimic

#3 Updated by Patrick Donnelly 6 months ago

  • Copied to Backport #24696: luminous: mds: low wrlock efficiency due to dirfrags traversal added

#4 Updated by Patrick Donnelly 6 months ago

  • Copied to Backport #24704: mimic: mds: low wrlock efficiency due to dirfrags traversal added

#5 Updated by Patrick Donnelly 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF