Project

General

Profile

Bug #24437

Mimic build fails with -DWITH_RADOSGW=0

Added by David Disseldorp 8 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/06/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Mimic branch at: 6a21295f7f6e7e0363bcfd30d2daf90561ef490c

../../../lib/libcephd.a(libcephd.cc.o): In function `cephd_run_rgw':
/home/ddiss/isms/ceph/src/libcephd/libcephd.cc:256: undefined reference to `cephd_rgw'
../../../lib/libcephd.a(libcephd.cc.o): In function `cephd_run_rgw_admin':
/home/ddiss/isms/ceph/src/libcephd/libcephd.cc:261: undefined reference to `cephd_rgw_admin'
collect2: error: ld returned 1 exit status
src/test/libcephd/CMakeFiles/ceph_test_cephd_api_misc.dir/build.make:148: recipe for target 'bin/ceph_test_cephd_api_misc' failed
make[2]: *** [bin/ceph_test_cephd_api_misc] Error 1
CMakeFiles/Makefile2:13414: recipe for target 'src/test/libcephd/CMakeFiles/ceph_test_cephd_api_misc.dir/all' failed
make[1]: *** [src/test/libcephd/CMakeFiles/ceph_test_cephd_api_misc.dir/all] Error 2

It seems that this bug isn't present in master, due to the inclusion of:

commit 39b2626c7a36b3fef8d97cd276e23dc6f1f197f3
Author: Dan Mick <dan.mick@redhat.com>
Date:   Tue May 8 19:24:17 2018 -0700

    Remove embedded 'cephd' code

... The commit message doesn't shed any light on the reason for this change.

A more minimal fix would be:

diff --git a/src/libcephd/libcephd.cc b/src/libcephd/libcephd.cc
index 71b0767f03..7e600bcaeb 100644
--- a/src/libcephd/libcephd.cc
+++ b/src/libcephd/libcephd.cc
@@ -232,8 +232,10 @@ void cephd_preload_rados_classes(OSD *osd)
 extern "C" int cephd_mon(int argc, const char **argv);
 extern "C" int cephd_osd(int argc, const char **argv);
 extern "C" int cephd_mds(int argc, const char **argv);
+#ifdef WITH_RADOSGW
 extern "C" int cephd_rgw(int argc, const char **argv);
 extern "C" int cephd_rgw_admin(int argc, const char **argv);
+#endif

 int cephd_run_mon(int argc, const char **argv)
 {
@@ -250,7 +252,7 @@ int cephd_run_mds(int argc, const char **argv)
     return cephd_mds(argc, argv);
 }

-
+#ifdef WITH_RADOSGW
 int cephd_run_rgw(int argc, const char **argv)
 {   
     return cephd_rgw(argc, argv);
@@ -260,3 +262,4 @@ int cephd_run_rgw_admin(int argc, const char **argv)
 {   
     return cephd_rgw_admin(argc, argv);
 }
+#endif

I'm curious to hear whether others would prefer a mimic backport of 39b2626c7a36b3fef8d97cd276e23dc6f1f197f3 , or the minimal change above.


Related issues

Copied to Ceph - Backport #24766: mimic: Mimic build fails with -DWITH_RADOSGW=0 Resolved
Copied to Ceph - Backport #24774: luminous: Mimic build fails with -DWITH_RADOSGW=0 Resolved

History

#1 Updated by Nathan Cutler 7 months ago

  • Project changed from ceph-qa-suite to Ceph

moving to Ceph in hopes of getting attention (the ceph-qa-suite project is not heavily used)

#2 Updated by John Spray 7 months ago

  • Status changed from New to Resolved

I think Patrick noticed and fixed the same issue here: https://github.com/ceph/ceph/pull/16574/files

(Haven't looked closely but he's removing cephd stuff from a target)

#3 Updated by Nathan Cutler 7 months ago

  • Description updated (diff)

#4 Updated by Nathan Cutler 7 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to mimic

#5 Updated by Nathan Cutler 7 months ago

@John, David reported that the problem occurs in mimic as of 6a21295f7f6e7e0363bcfd30d2daf90561ef490c which, AFAICT, already contains Patrick's fix from https://github.com/ceph/ceph/pull/16574

In response to David's question whether to backport 39b2626c7a36b3fef8d97cd276e23dc6f1f197f3 or use his proposed minimal change, the minimal change looks completely innocuous and safe, but this early in the mimic release cycle I would lean towards the cherry-pick as long as the leads think it's safe.

#6 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #24766: mimic: Mimic build fails with -DWITH_RADOSGW=0 added

#7 Updated by Nathan Cutler 7 months ago

  • Backport changed from mimic to mimic,luminous

#8 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #24774: luminous: Mimic build fails with -DWITH_RADOSGW=0 added

#9 Updated by Nathan Cutler 4 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF