Project

General

Profile

Bug #24369

luminous: checking quota while holding cap ref may deadlock

Added by Zheng Yan 10 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/01/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Client
Labels (FS):
Pull request ID:

History

#1 Updated by Zheng Yan 10 months ago

For example:

mds revokes an inode's Fw
mds freezes the subtree that contains the inode

client::_write() calls is_quota_bytes_approaching() while holding the inode's Fw. Client::get_quota_root() sends lookup_name request to mds.
mds delays handling the lookup_name request because subtree is freezing.

#2 Updated by Zheng Yan 10 months ago

  • Status changed from New to Need Review

#3 Updated by Patrick Donnelly 10 months ago

  • Assignee set to Zheng Yan
  • Target version set to v12.2.6
  • Source set to Development
  • Affected Versions v12.2.5 added
  • Component(FS) Client added

#4 Updated by Yuri Weinstein 10 months ago

#5 Updated by Zheng Yan 10 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF