Project

General

Profile

Bug #24239

cephfs-journal-tool: Importing a zero-length purge_queue journal breaks its integrity.

Added by yupeng chen 7 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
fsck/damage handling
Target version:
Start date:
05/23/2018
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
tools
Labels (FS):
Pull request ID:

Description

When we were importing a zero-length purge_queue journal exported previously, the last object and
the following one were purged for removing potential junks.
However, in this case, no writing were actually performed because of the zero length, so the purged last object get lost permanently.

This can be fixed by purging the object following the last object, and by zeroing the last object
starting from the offset determined by the write_pos.

PR comes here:

https://github.com/ceph/ceph/pull/22144


Related issues

Copied to fs - Backport #24860: luminous: cephfs-journal-tool: Importing a zero-length purge_queue journal breaks its integrity. Resolved
Copied to fs - Backport #24861: mimic: cephfs-journal-tool: Importing a zero-length purge_queue journal breaks its integrity. Resolved

History

#1 Updated by Patrick Donnelly 7 months ago

  • Status changed from New to Need Review
  • Priority changed from Normal to High
  • Target version set to v14.0.0
  • Backport set to mimic,luminous

#2 Updated by Patrick Donnelly 5 months ago

  • Status changed from Need Review to Pending Backport
  • Assignee set to yupeng chen

#3 Updated by Patrick Donnelly 5 months ago

  • Copied to Backport #24860: luminous: cephfs-journal-tool: Importing a zero-length purge_queue journal breaks its integrity. added

#4 Updated by Patrick Donnelly 5 months ago

  • Copied to Backport #24861: mimic: cephfs-journal-tool: Importing a zero-length purge_queue journal breaks its integrity. added

#5 Updated by Nathan Cutler 5 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF