Project

General

Profile

Bug #24167

Module 'balancer' has failed: could not find bucket -14

Added by Sage Weil 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
05/17/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

crushmap may contain choose_args for deleted buckets

            {
                "bucket_id": -14,
                "weight_set": [
                    []
                ]
            },

in teh choose_args section, but bucket -14 doesn't exist. THis is because it used to exist when the weight-set was created, but then was deleted, and the choose_args weights are still there.

Related issues

Copied to RADOS - Backport #24213: mimic: Module 'balancer' has failed: could not find bucket -14 Resolved
Copied to RADOS - Backport #24214: luminous: Module 'balancer' has failed: could not find bucket -14 Resolved

History

#1 Updated by Sage Weil 8 months ago

It looks like we also don't create weight-sets for new buckets. And if you create buckets and move things into them and try to set the weight-set weight on them you get something like

gnit:build (wip-24167) 05:08 PM $ bin/ceph osd crush weight-set reweight-compat osd.0 1.0
Error ENOENT: no weight-set for bucket -5no weight-set for bucket -6no weight-set for bucket -7no weight-set for bucket -8item 0 not found in crush map

#2 Updated by Sage Weil 8 months ago

  • Status changed from In Progress to Need Review

#3 Updated by Sage Weil 8 months ago

  • Status changed from Need Review to Pending Backport
  • Backport set to mimic,luminous

#5 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #24213: mimic: Module 'balancer' has failed: could not find bucket -14 added

#6 Updated by Nathan Cutler 8 months ago

  • Copied to Backport #24214: luminous: Module 'balancer' has failed: could not find bucket -14 added

#7 Updated by Nathan Cutler 7 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF